summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-29 19:29:15 -0700
committerAnatol Pomozov2015-06-29 19:29:15 -0700
commit259755f382ff50c21ffa07447d9024026c8f9835 (patch)
treef2e2ea5342b2a50a1a0bda59fa4adc5a9d6ac516
parente913f44dcb6c1c0f20a13a1ebf067ba80284c62e (diff)
downloadaur-259755f382ff50c21ffa07447d9024026c8f9835.tar.gz
updpkg
-rw-r--r--.SRCINFO18
-rw-r--r--0001-Fix-compilation-error-found-at-Linux-Arch.patch (renamed from 0001-Fix-compilation-error.patch)6
-rw-r--r--0002-Use-usr-share-for-resource-files-bin-folder-is-for-b.patch (renamed from 0002-Instead-of-polluting-bin-use-usr-share-path-for-reso.patch)44
-rw-r--r--0003-Fix-compile-error.patch34
-rw-r--r--PKGBUILD31
5 files changed, 95 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e164c71b827c..aa7942d0d6ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dsview-git
pkgdesc = GUI programe for supporting various instruments from DreamSourceLab, including logic analyzer, oscilloscope, etc.
- pkgver = 0.93.r1.g71d0f5a
+ pkgver = 0.93.r33.g8f56a5e
pkgrel = 1
url = http://www.dreamsourcelab.com/
install = dsview.install
@@ -14,15 +14,17 @@ pkgbase = dsview-git
depends = libsigrok4dsl-git
depends = libsigrokdecode
source = git://github.com/DreamSourceLab/DSView
- source = 0001-Fix-compilation-error.patch
- source = 0002-Instead-of-polluting-bin-use-usr-share-path-for-reso.patch
+ source = 0001-Fix-compilation-error-found-at-Linux-Arch.patch
+ source = 0002-Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
+ source = 0003-Fix-compile-error.patch
source = udev.rules
source = dsview.desktop
- md5sums = SKIP
- md5sums = 1e65dd1e0a3154296f37429ff2f6e817
- md5sums = da765c96fbe56910e32755995ec3616a
- md5sums = 9a0a3d388369283019d7f0efa8d0c8a6
- md5sums = 095886809795b40d663bfe4b79395811
+ sha1sums = SKIP
+ sha1sums = e5ae41c0157e8e318866be7785ff9bee3198d387
+ sha1sums = 0fe0fb09ce13383c26c39f016d23a37a9af82bef
+ sha1sums = 64fb34f100c4a94ab497581a871f006012727b5c
+ sha1sums = 3f926508405a6546d31a819cc0909d312f0f0cdc
+ sha1sums = 2354eb8d1140e8e3ce523122a52a5d07fa80f739
pkgname = dsview-git
diff --git a/0001-Fix-compilation-error.patch b/0001-Fix-compilation-error-found-at-Linux-Arch.patch
index c8f5fc69c5a5..b9947d81661b 100644
--- a/0001-Fix-compilation-error.patch
+++ b/0001-Fix-compilation-error-found-at-Linux-Arch.patch
@@ -1,7 +1,7 @@
-From a55609ad36a768a8e70c242719b050902c99c2d2 Mon Sep 17 00:00:00 2001
+From 5270c97b76674d6f19fd14758d443cfda44c0036 Mon Sep 17 00:00:00 2001
From: Anatol Pomozov <anatol.pomozov@gmail.com>
Date: Fri, 15 May 2015 16:04:00 -0700
-Subject: [PATCH 1/2] Fix compilation error
+Subject: [PATCH 1/4] Fix compilation error found at Linux Arch
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@@ -27,5 +27,5 @@ index 32d3897..c3c7440 100644
const char *const *annotations = (char**)pda->ann_text;
while(*annotations) {
--
-2.4.1
+2.4.4
diff --git a/0002-Instead-of-polluting-bin-use-usr-share-path-for-reso.patch b/0002-Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
index 037c7e9ff925..4e9894e7d54b 100644
--- a/0002-Instead-of-polluting-bin-use-usr-share-path-for-reso.patch
+++ b/0002-Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
@@ -1,19 +1,19 @@
-From f8cb9408922e777cd688787dd373faaf27650ca0 Mon Sep 17 00:00:00 2001
+From 691a7be3dbf7b0685d410a88efd57bfc6ca41ec1 Mon Sep 17 00:00:00 2001
From: Anatol Pomozov <anatol.pomozov@gmail.com>
Date: Fri, 15 May 2015 16:28:42 -0700
-Subject: [PATCH 2/2] Instead of polluting bin use /usr/share/ path for
- resources
+Subject: [PATCH 2/4] Use /usr/share for resource files bin folder is for
+ binaries.
---
- DSView/CMakeLists.txt | 14 +++++++-------
- DSView/pv/devicemanager.cpp | 4 ++++
- 2 files changed, 11 insertions(+), 7 deletions(-)
+ DSView/CMakeLists.txt | 30 +++++++++++++++---------------
+ DSView/pv/devicemanager.cpp | 5 +++++
+ 2 files changed, 20 insertions(+), 15 deletions(-)
diff --git a/DSView/CMakeLists.txt b/DSView/CMakeLists.txt
-index 2f5eb78..1882843 100644
+index 652cb58..9c146b8 100644
--- a/DSView/CMakeLists.txt
+++ b/DSView/CMakeLists.txt
-@@ -350,13 +350,13 @@ set_target_properties(${PROJECT_NAME} PROPERTIES INSTALL_RPATH "/usr/local/lib")
+@@ -350,21 +350,21 @@ set_target_properties(${PROJECT_NAME} PROPERTIES INSTALL_RPATH "/usr/local/lib")
# Install the executable.
install(TARGETS ${PROJECT_NAME} DESTINATION bin/)
@@ -24,6 +24,14 @@ index 2f5eb78..1882843 100644
-install(FILES res/DSLogicPro.bin DESTINATION bin/res/)
-install(FILES res/DSCope.fw DESTINATION bin/res/)
-install(FILES res/DSCope.bin DESTINATION bin/res/)
+-install(FILES res/DSLogic0.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic0.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic1.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic1.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic2.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic2.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSCope1.dsc DESTINATION bin/res/)
+-install(FILES res/DSCope1.def.dsc DESTINATION bin/res/)
+install(FILES res/DSLogic.fw DESTINATION share/dsview/)
+install(FILES res/DSLogic33.bin DESTINATION share/dsview/)
+install(FILES res/DSLogic50.bin DESTINATION share/dsview/)
@@ -31,14 +39,22 @@ index 2f5eb78..1882843 100644
+install(FILES res/DSLogicPro.bin DESTINATION share/dsview/)
+install(FILES res/DSCope.fw DESTINATION share/dsview/)
+install(FILES res/DSCope.bin DESTINATION share/dsview/)
++install(FILES res/DSLogic0.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic0.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic1.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic1.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic2.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic2.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSCope1.dsc DESTINATION share/dsview/)
++install(FILES res/DSCope1.def.dsc DESTINATION share/dsview/)
#===============================================================================
#= Packaging (handled by CPack)
diff --git a/DSView/pv/devicemanager.cpp b/DSView/pv/devicemanager.cpp
-index e4a2b6e..b94cbf3 100644
+index a3d6d21..99b49ec 100644
--- a/DSView/pv/devicemanager.cpp
+++ b/DSView/pv/devicemanager.cpp
-@@ -103,11 +103,15 @@ std::list<boost::shared_ptr<device::DevInst> > DeviceManager::driver_scan(
+@@ -103,12 +103,17 @@ std::list<boost::shared_ptr<device::DevInst> > DeviceManager::driver_scan(
// Check If DSL hardware driver
if (strcmp(driver->name, "demo") != 0) {
@@ -46,14 +62,16 @@ index e4a2b6e..b94cbf3 100644
QDir dir(QCoreApplication::applicationDirPath());
if (!dir.cd("res"))
return driver_devices;
- std::string str = dir.absolutePath().toStdString() + "/";
- strcpy(config_path, str.c_str());
+ QString str = dir.absolutePath() + "/";
+ QString str_utf8 = QString::fromLocal8Bit(str.toLocal8Bit());
+ strcpy(config_path, str_utf8.toUtf8().data());
+ */
+ // dirty
++ // maybe use QStandardPaths::standardLocations(QStandardPaths::AppDataLocation);
+ strcpy(config_path, "/usr/share/dsview/");
}
// Do the scan
--
-2.4.1
+2.4.4
diff --git a/0003-Fix-compile-error.patch b/0003-Fix-compile-error.patch
new file mode 100644
index 000000000000..097ce430c859
--- /dev/null
+++ b/0003-Fix-compile-error.patch
@@ -0,0 +1,34 @@
+From 35fc34271fbbd6f504aa428e7da45bfb3c8b7a44 Mon Sep 17 00:00:00 2001
+From: Anatol Pomozov <anatol.pomozov@gmail.com>
+Date: Mon, 29 Jun 2015 19:11:19 -0700
+Subject: [PATCH 3/4] Fix compile error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+/home/anatol/sources/dreamstudio/DSView/DSView/pv/mainwindow.cpp: In member function ‘bool pv::MainWindow
+/home/anatol/sources/dreamstudio/DSView/DSView/pv/mainwindow.cpp:742:77: error: conversion from ‘uint64_t
+ s_obj["vdiv"] = QJsonValue::fromVariant(dsoSig->get_vDialValue());
+ ^
+---
+ DSView/pv/mainwindow.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/DSView/pv/mainwindow.cpp b/DSView/pv/mainwindow.cpp
+index a00cc67..00ef817 100644
+--- a/DSView/pv/mainwindow.cpp
++++ b/DSView/pv/mainwindow.cpp
+@@ -739,8 +739,8 @@ bool MainWindow::store_session(QString name)
+ s_obj["strigger"] = s->get_trig();
+ boost::shared_ptr<view::DsoSignal> dsoSig;
+ if (dsoSig = dynamic_pointer_cast<view::DsoSignal>(s)) {
+- s_obj["vdiv"] = QJsonValue::fromVariant(dsoSig->get_vDialValue());
+- s_obj["vfactor"] = QJsonValue::fromVariant(dsoSig->get_factor());
++ s_obj["vdiv"] = QJsonValue::fromVariant(static_cast<qulonglong>(dsoSig->get_vDialValue()));
++ s_obj["vfactor"] = QJsonValue::fromVariant(static_cast<qulonglong>(dsoSig->get_factor()));
+ s_obj["coupling"] = dsoSig->get_acCoupling();
+ s_obj["trigValue"] = dsoSig->get_trigRate();
+ s_obj["zeroPos"] = dsoSig->get_zeroRate();
+--
+2.4.4
+
diff --git a/PKGBUILD b/PKGBUILD
index 93d6ecfc3f3d..1887cb3398b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Thomas Krug <t.krug@elektronenpumpe.de>
pkgname=dsview-git
-pkgver=0.93.r1.g71d0f5a
+pkgver=0.93.r33.g8f56a5e
pkgrel=1
pkgdesc='GUI programe for supporting various instruments from DreamSourceLab, including logic analyzer, oscilloscope, etc.'
arch=(i686 x86_64)
@@ -11,30 +11,33 @@ license=(GPL3)
depends=(boost-libs qt5-base libsigrok4dsl-git libsigrokdecode)
makedepends=(boost cmake)
source=(git://github.com/DreamSourceLab/DSView
- 0001-Fix-compilation-error.patch
- 0002-Instead-of-polluting-bin-use-usr-share-path-for-reso.patch
+ 0001-Fix-compilation-error-found-at-Linux-Arch.patch
+ 0002-Use-usr-share-for-resource-files-bin-folder-is-for-b.patch
+ 0003-Fix-compile-error.patch
udev.rules
dsview.desktop)
-md5sums=('SKIP'
- '1e65dd1e0a3154296f37429ff2f6e817'
- 'da765c96fbe56910e32755995ec3616a'
- '9a0a3d388369283019d7f0efa8d0c8a6'
- '095886809795b40d663bfe4b79395811')
+sha1sums=('SKIP'
+ 'e5ae41c0157e8e318866be7785ff9bee3198d387'
+ '0fe0fb09ce13383c26c39f016d23a37a9af82bef'
+ '64fb34f100c4a94ab497581a871f006012727b5c'
+ '3f926508405a6546d31a819cc0909d312f0f0cdc'
+ '2354eb8d1140e8e3ce523122a52a5d07fa80f739')
install=dsview.install
pkgver() {
- cd "$srcdir/DSView"
+ cd DSView
git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/DSView"
- patch -p1 < "$srcdir/0001-Fix-compilation-error.patch"
- patch -p1 < "$srcdir/0002-Instead-of-polluting-bin-use-usr-share-path-for-reso.patch"
+ cd DSView
+ patch -p1 < "$srcdir/0001-Fix-compilation-error-found-at-Linux-Arch.patch"
+ patch -p1 < "$srcdir/0002-Use-usr-share-for-resource-files-bin-folder-is-for-b.patch"
+ patch -p1 < "$srcdir/0003-Fix-compile-error.patch"
}
build() {
- cd "$srcdir/DSView/DSView"
+ cd DSView/DSView
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_SKIP_RPATH=1 .
@@ -43,7 +46,7 @@ build() {
}
package() {
- cd "$srcdir/DSView/DSView"
+ cd DSView/DSView
make DESTDIR="$pkgdir" install