summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2022-07-28 14:49:36 +0200
committerPeter Mattern2022-07-28 16:40:57 +0200
commit1cfc2bcff408e5e027a383f715656359bf7e168b (patch)
tree3af1c841d6123024901a891b87510067f2656984
parentddd5506457523350331e4c66a40377dfce039ce2 (diff)
downloadaur-dunst-git.tar.gz
Update dependencies and build
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9536472dd05..73bfc8ed16e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dunst-git
pkgdesc = A highly configurable and lightweight notification daemon
- pkgver = 1.6.1.r13.g3acffdb
+ pkgver = 1.9.0.r3.g1ef38e5
pkgrel = 1
url = https://dunst-project.org/
arch = i686
@@ -8,20 +8,21 @@ pkgbase = dunst-git
arch = armv7h
license = BSD
makedepends = git
- makedepends = perl
- makedepends = dbus
makedepends = wayland-protocols
- makedepends = wayland
- depends = libxinerama
- depends = libxss
- depends = pango
- depends = libnotify
+ makedepends = libnotify
+ depends = systemd
depends = gdk-pixbuf2
- depends = libxdg-basedir
+ depends = pango
+ depends = libxss
+ depends = libxinerama
depends = libxrandr
+ depends = wayland
+ optdepends = libnotify: dunstify
+ optdepends = xdg-utils: xdg-open
provides = dunst
provides = notification-daemon
conflicts = dunst
+ backup = etc/xdg/dunst/dunstrc
source = git+https://github.com/dunst-project/dunst.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ce23c79f2cc2..12a051ebb6eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,19 @@
_pkgname=dunst
pkgname=${_pkgname}-git
-pkgver=1.6.1.r13.g3acffdb
+pkgver=1.9.0.r3.g1ef38e5
pkgrel=1
pkgdesc="A highly configurable and lightweight notification daemon"
arch=('i686' 'x86_64' 'armv7h')
url="https://dunst-project.org/"
license=('BSD')
-depends=('libxinerama' 'libxss' 'pango' 'libnotify' 'gdk-pixbuf2' 'libxdg-basedir' 'libxrandr')
-makedepends=('git' 'perl' 'dbus' 'wayland-protocols' 'wayland')
+depends=('systemd' 'gdk-pixbuf2' 'pango' 'libxss' 'libxinerama' 'libxrandr' 'wayland')
+makedepends=('git' 'wayland-protocols' 'libnotify')
+optdepends=("libnotify: dunstify"
+ "xdg-utils: xdg-open")
provides=('dunst' 'notification-daemon')
conflicts=('dunst')
+backup=('etc/xdg/dunst/dunstrc')
source=('git+https://github.com/dunst-project/dunst.git')
sha256sums=('SKIP')
@@ -27,14 +30,11 @@ pkgver() {
build() {
cd "${_pkgname}"
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
+ make PREFIX=/usr SYSCONFDIR=/etc/xdg
}
package() {
cd "${_pkgname}"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
- install -Dm755 dunstify "${pkgdir}"/usr/bin/dunstify
- install -Dm755 contrib/dunst_espeak.sh "${pkgdir}"/usr/bin/dunst_espeak.sh
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ make DESTDIR="${pkgdir}" PREFIX=/usr SYSCONFDIR=/etc/xdg install
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
}