summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2018-11-12 19:58:06 +0100
committerfuan_k2018-11-12 19:58:06 +0100
commit4038da434a8c10c5e96caaea959c617b339cb220 (patch)
tree6455479e4e05b4e224d02edec172afab815de9cd
parentf0a1a2ad0b6a88217e1645c04757b0de8fa10c35 (diff)
downloadaur-4038da434a8c10c5e96caaea959c617b339cb220.tar.gz
Temporary fix for python3.7 handling of old syntax during build
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d8dbc57ad4a..cfb7852d9801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
+# Maintainer: fuan_k <rrkay at posteo dot net>
# Maintainer: Bijaya Dangol <dangoldbj23@gmail.com>
+# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
pkgname=dupeguru
pkgver=4.0.3
pkgrel=5
@@ -20,6 +21,17 @@ md5sums=(
provides=("dupeguru")
conflicts=("dupeguru-se" "dupeguru-pe" "dupeguru-me")
+prepare(){
+ # Temporary fix for python3.7 handling of old syntax
+ cd "$srcdir"
+ sed -i '277 a\\ try:' src/hscommon/build.py
+ sed -i '279s/^/ /' src/hscommon/build.py
+ sed -i '280s/^/ /' src/hscommon/build.py
+ sed -i '281s/^/ /' src/hscommon/build.py
+ sed -i '281a\\ except StopIteration:' src/hscommon/build.py
+ sed -i '282a\\ return' src/hscommon/build.py
+}
+
build() {
cd "$srcdir"
python3 -m venv env --system-site-packages