summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2020-12-10 20:49:52 +0100
committerfuan_k2020-12-10 20:49:52 +0100
commita7313179e37e72b871bead816be1bb984a86c528 (patch)
treeae10a98decf04c5ae308b5bea59f7eb76fb89e29
parenta8cdc49e6b23e89eb08a12e77fca03e020ef6c94 (diff)
downloadaur-a7313179e37e72b871bead816be1bb984a86c528.tar.gz
Remove deps handled by pip
* Send2trash is currently fetched with pip, not from the Arch repos * Most dependencies are handled with pip, which might not be ideal but works fine for now
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ad8312e4352..e5ed49e2b5f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dupeguru
pkgdesc = Find duplicate files on your system
pkgver = 4.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://dupeguru.voltaicideas.net/
arch = x86_64
license = GPL3
@@ -9,7 +9,6 @@ pkgbase = dupeguru
depends = python
depends = python-pyqt5
depends = libxkbcommon-x11
- depends = python-send2trash
provides = dupeguru
conflicts = dupeguru-git
conflicts = dupeguru-se
diff --git a/PKGBUILD b/PKGBUILD
index 81f8d43f1ad0..429f87588e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,13 @@
pkgname=dupeguru
pkgver=4.1.0
_pkgver="${pkgver}-alpha"
-pkgrel=1
+pkgrel=2
pkgdesc="Find duplicate files on your system"
arch=('x86_64')
url="https://dupeguru.voltaicideas.net/"
license=('GPL3')
-depends=('python' 'python-pyqt5' 'libxkbcommon-x11' 'python-send2trash')
-makedepends=(
- python-sphinx
-)
+depends=('python' 'python-pyqt5' 'libxkbcommon-x11')
+makedepends=('python-sphinx')
source=(
https://github.com/glubsy/${pkgname}/releases/download/${_pkgver}/dupeguru-src-${_pkgver}.tar.xz
)
@@ -34,9 +32,7 @@ build() {
# Instead of doing the full ./bootstrap.sh
python3 -m venv env --system-site-packages
source env/bin/activate
- #python -m pip install --no-index --find-links=deps -r requirements.txt
- ./env/bin/pip install -r requirements.txt
- source env/bin/activate
+ python3 -m pip install -r requirements.txt
msg "Starting build..."
python build.py --clean
}