summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2017-10-25 11:02:16 -0400
committerJoey Dumont2017-10-25 11:02:16 -0400
commit08ac29be293c0a965fc76ecd602ee1df53bb1895 (patch)
tree34a27aeb11852ff99f49191fd1608670efa32750
parent019edfc9448e275be710122bae0ce3f0dddfe012 (diff)
downloadaur-08ac29be293c0a965fc76ecd602ee1df53bb1895.tar.gz
Added dupliati-cli alias, as described in https://github.com/duplicati/duplicati/wiki/Headless-installation-on-Debian-or-Ubuntu.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--duplicati-cli9
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f353788d587..1d2eb9e807e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Oct 22 13:57:47 UTC 2017
+# Wed Oct 25 15:01:22 UTC 2017
pkgbase = duplicati-latest
pkgdesc = A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers
pkgver = 2.0.2.12
- pkgrel = 1
+ pkgrel = 2
url = http://duplicati.com
install = duplicati.install
arch = i686
@@ -15,10 +15,12 @@ pkgbase = duplicati-latest
source = duplicati-user.service
source = duplicati.service
source = duplicati.sysusers
+ source = duplicati-cli
sha256sums = 0ee644e2e65856ab59b2e1b39cf6a45c207132a84967a4d3ff70b243edff9b68
sha256sums = ec25b25d0e331ddfb90940555068aa941c3d5dfaf858cffb6c75e810175c9d27
sha256sums = 087db7ce97c4180006c2708d49024c0393f48f83ea2ce8b0b6354fffa554ece9
sha256sums = b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959
+ sha256sums = f6f903ca443935314afeab4cd2e46cf4bef7c5fb1e81c2d95f670f0993774ce5
pkgname = duplicati-latest
diff --git a/PKGBUILD b/PKGBUILD
index beb7ab7791b3..eab3d4747085 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=duplicati-latest
pkgver=2.0.2.12
-pkgrel=1
+pkgrel=2
_date=2017-10-20
_branch=canary
pkgdesc='A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers'
@@ -14,11 +14,13 @@ install=duplicati.install
source=(https://github.com/duplicati/duplicati/releases/download/v${pkgver}-${pkgver}_${_branch}_${_date}/duplicati-${pkgver}_${_branch}_${_date}.zip
duplicati-user.service
duplicati.service
- duplicati.sysusers)
+ duplicati.sysusers
+ duplicati-cli)
sha256sums=('0ee644e2e65856ab59b2e1b39cf6a45c207132a84967a4d3ff70b243edff9b68'
'ec25b25d0e331ddfb90940555068aa941c3d5dfaf858cffb6c75e810175c9d27'
'087db7ce97c4180006c2708d49024c0393f48f83ea2ce8b0b6354fffa554ece9'
- 'b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959')
+ 'b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959'
+ 'f6f903ca443935314afeab4cd2e46cf4bef7c5fb1e81c2d95f670f0993774ce5')
arch=('i686' 'x86_64')
depends=('gtk-sharp-2' 'mono')
@@ -33,4 +35,7 @@ package() {
rm *.zip
mkdir -p "${pkgdir}/opt/duplicati-latest"
cp -r . "${pkgdir}/opt/duplicati-latest"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ install -D -m755 duplicati-cli "${pkgdir}/usr/bin"
}
diff --git a/duplicati-cli b/duplicati-cli
new file mode 100644
index 000000000000..f14019e6a0ed
--- /dev/null
+++ b/duplicati-cli
@@ -0,0 +1,9 @@
+#!/bin/bash
+INSTALLDIR=/opt/duplicati-latest/
+export LD_LIBRARY_PATH="${INSTALLDIR}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+export MONO_PATH=$MONO_PATH:${INSTALLDIR}
+
+EXE_FILE=${INSTALLDIR}/Duplicati.CommandLine.exe
+APP_NAME=Duplicati.CommandLine
+
+exec -a "$APP_NAME" mono "$EXE_FILE" "$@" \ No newline at end of file