summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-06-28 14:41:00 +0200
committerJaroslav Lichtblau2015-06-28 14:41:00 +0200
commit34e40f57f9f9d74b1c8df4cabb0bea222686229b (patch)
tree97a34f7cab450cc58042579eef779f3665008297
downloadaur-34e40f57f9f9d74b1c8df4cabb0bea222686229b.tar.gz
dvd-slideshow moved from [community] to AUR
FS#45154 - [dvd-slideshow] not working with latest sox and ffmpeg
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
-rw-r--r--dvd-slideshow.install4
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d666d5fd9e71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dvd-slideshow
+ pkgdesc = Scripts for creating slideshow DVDs with menus, audio, and fancy effects
+ pkgver = 0.8.4
+ pkgrel = 3
+ url = http://dvd-slideshow.sourceforge.net
+ install = dvd-slideshow.install
+ arch = any
+ license = GPL
+ depends = bc
+ depends = cdrkit
+ depends = dvdauthor
+ depends = jhead
+ depends = netpbm
+ depends = sox
+ depends = toolame
+ depends = transcode
+ depends = vorbis-tools
+ source = http://downloads.sourceforge.net/dvd-slideshow/dvd-slideshow-0.8.4-1.tar.gz
+ sha256sums = 484f71614ab45205f6133829c431b9a631cb0251de9b97993a9361648d0607e7
+
+pkgname = dvd-slideshow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6dba8034c46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Tim Yang <tdy@gmx.com>
+# Contributor: JJDaNiMoTh <jjdanimoth.aur@gmail.com>
+# Contributor: Travis Nickles <ryoohki7@yahoo.com>
+# Contributor: Haw-Bin Chai <hbchai@gmail.com>
+
+pkgname=dvd-slideshow
+pkgver=0.8.4
+pkgrel=3
+pkgdesc="Scripts for creating slideshow DVDs with menus, audio, and fancy effects"
+arch=('any')
+url="http://dvd-slideshow.sourceforge.net"
+license=('GPL')
+depends=('bc' 'cdrkit' 'dvdauthor' 'jhead' 'netpbm' 'sox' 'toolame' 'transcode' 'vorbis-tools')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-1.tar.gz)
+sha256sums=('484f71614ab45205f6133829c431b9a631cb0251de9b97993a9361648d0607e7')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}-1"
+
+ for _file in `ls man | sed 's/\.1//'`; do
+ install -Dm755 $_file "${pkgdir}/usr/bin/$_file"
+ install -Dm644 man/$_file.1 "${pkgdir}/usr/share/man/man1/$_file.1"
+ install -Dm644 doc/$_file.html "${pkgdir}/usr/share/doc/$pkgname/$_file.html"
+ done
+
+ install -Dm644 "${pkgname}rc" "${pkgdir}/usr/share/$pkgname/${pkgname}rc"
+}
diff --git a/dvd-slideshow.install b/dvd-slideshow.install
new file mode 100644
index 000000000000..7ccfeb904ae1
--- /dev/null
+++ b/dvd-slideshow.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "==> A sample configuration file is included:"
+ echo "==> cp /usr/share/dvd-slideshow/dvd-slideshowrc ~/.dvd-slideshowrc"
+}