summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-04 22:04:31 -0500
committerDan Beste2017-04-04 22:04:31 -0500
commit9d05531a30e3d7712333386990e4a42175446982 (patch)
tree6cd756cfa270ee7737130f880ba26e1bf887626e
parentfbb2386f7339ebeb2b09bd5e8142628fb8ebf14a (diff)
downloadaur-9d05531a30e3d7712333386990e4a42175446982.tar.gz
PKGBUILD - Remove unneeded code
Removed unneeded '|| exit 1's. Additional changes in the diff.
-rw-r--r--PKGBUILD36
1 files changed, 13 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e43965b059e..8f937e6b0462 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-maintainer: Dan Beste <dan.ray.beste@gmail.com>
pkgname=dybuk-git
-_pkgname=dybuk
+gitname=dybuk
pkgver=r37.ef12906
pkgrel=1
pkgdesc='Prettify the ugly Rustc messages'
@@ -11,29 +11,19 @@ arch=(
'x86_64'
)
url='https://github.com/Ticki/dybuk'
-license=(
- 'MIT'
-)
+license=('MIT')
makedepends=(
'cargo'
'git'
'rust'
)
-provides=(
- "${_pkgname}"
-)
-conflicts=(
- "${_pkgname}"
-)
-source=(
- 'git+https://github.com/Ticki/dybuk.git'
-)
-sha256sums=(
- 'SKIP'
-)
+provides=("${gitname}")
+conflicts=("${gitname}")
+source=('git+https://github.com/Ticki/dybuk.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${gitname}"
printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
@@ -41,16 +31,16 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${gitname}"
cargo build --release
}
package() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${gitname}"
- install -m755 \
- -D "target/release/dybuk" "${pkgdir}/usr/bin/${_pkgname}"
- install -m644 \
- -D "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -m 755 \
+ -D target/release/dybuk "${pkgdir}/usr/bin/${gitname}"
+ install -m 644 \
+ -D LICENSE "${pkgdir}/usr/share/licenses/${gitname}/LICENSE"
}