summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-01 13:07:03 +0800
committerzxp198210052024-03-01 13:07:03 +0800
commit360b0e527dd0cebbd363fa9b7b8c66c6e641099b (patch)
tree1ebad9a82d874083f6beebade7a0b52a3df5a039
parentafc2e7bae6b5ab25e19babd114f3ba181e744dae (diff)
downloadaur-easyconnect.tar.gz
fix errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
-rw-r--r--easyconnect.sh1
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4fa59626849..58aadef8c290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
pkgbase = easyconnect
pkgdesc = Support access to ssl vpn. With easyconect,you can secure and speed up connection to cooperate network at ease!
pkgver = 7.6.7.3
- pkgrel = 9
+ pkgrel = 10
url = http://www.sangfor.com.cn
install = easyconnect.install
arch = x86_64
license = LicenseRef-custom
makedepends = gobject-introspection
- depends = dbus-glib
depends = gtk2
- depends = lib32-gtk2
- depends = at-spi2-core
- depends = gdk-pixbuf2
depends = alsa-lib
depends = nss
depends = sqlite
depends = nspr
+ depends = dbus-glib
conflicts = easyconnect
conflicts = easyconnect-rpc
conflicts = easyconnect-zjjy
conflicts = easyconnect-sdu
conflicts = easyconnect-cas
+ options = !strip
+ options = !emptydirs
source = easyconnect-7.6.7.3.deb::https://download.sangfor.com.cn/download/product/sslvpn/pkg/linux_767/EasyConnect_x64_7_6_7_3.deb
source = pango-1.42.4.tar.xz::https://download.gnome.org/sources/pango/1.42/pango-1.42.4.tar.xz
source = LICENSE
@@ -28,6 +27,6 @@ pkgbase = easyconnect
sha256sums = ae623c6dc0354ff87afefbb770de5013bfd943051c9a653b93db708253b2f0d3
sha256sums = 1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d
sha256sums = b4b0db5e577c1b565a7f065ce8f9a4f9622b673fbcffa27ccbaf68f061a67a68
- sha256sums = a2576d121dc6bf868b351e5c39c8e4f1ee9de154c28dc7d6f7331cbbc0684b5a
+ sha256sums = 3e7bc24bf8590a5d428bc2bdd54938fb80f4d4be23631ceafd492495a327a248
pkgname = easyconnect
diff --git a/PKGBUILD b/PKGBUILD
index 31e4296d5581..efecf060f284 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=easyconnect
_pkgname=EasyConnect
pkgver=7.6.7.3
-_electronversion=2
-pkgrel=9
+_electronversion=1
+pkgrel=10
_pangover=1.42.4
pkgdesc="Support access to ssl vpn. With easyconect,you can secure and speed up connection to cooperate network at ease!"
arch=('x86_64')
@@ -19,20 +19,21 @@ conflicts=(
"${pkgname}-cas"
)
depends=(
- 'dbus-glib'
'gtk2'
- 'lib32-gtk2'
- 'at-spi2-core'
- 'gdk-pixbuf2'
'alsa-lib'
'nss'
'sqlite'
'nspr'
+ 'dbus-glib'
)
makedepends=(
'gobject-introspection'
)
install="${pkgname}.install"
+options=(
+ '!strip'
+ '!emptydirs'
+)
source=(
"${pkgname}-${pkgver}.deb::https://download.sangfor.com.cn/download/product/sslvpn/pkg/linux_767/${_pkgname}_x64_${pkgver//./_}.deb"
"pango-${_pangover}.tar.xz::https://download.gnome.org/sources/pango/${_pangover%.4}/pango-${_pangover}.tar.xz"
@@ -42,14 +43,13 @@ source=(
sha256sums=('ae623c6dc0354ff87afefbb770de5013bfd943051c9a653b93db708253b2f0d3'
'1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d'
'b4b0db5e577c1b565a7f065ce8f9a4f9622b673fbcffa27ccbaf68f061a67a68'
- 'a2576d121dc6bf868b351e5c39c8e4f1ee9de154c28dc7d6f7331cbbc0684b5a')
+ '3e7bc24bf8590a5d428bc2bdd54938fb80f4d4be23631ceafd492495a327a248')
build() {
sed -e "s|@appname@|sangfor|g" \
-e "s|@runpath@|${_pkgname}|g" \
-e "s|@runname@|${_pkgname}|g" \
-i "${srcdir}/${pkgname}.sh"
- bsdtar -xf "${srcdir}/data.tar.gz"
- bsdtar -xf "${srcdir}/pango-${_pangover}.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
cd "${srcdir}/pango-${_pangover}"
./configure --prefix=/usr
make -j4 && make DESTDIR="${srcdir}/pango" install
diff --git a/easyconnect.sh b/easyconnect.sh
index dc8830196f9e..6bbba417226b 100644
--- a/easyconnect.sh
+++ b/easyconnect.sh
@@ -5,6 +5,7 @@ _RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${_APPDIR}/resources/lib64:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then