summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMounir Erhili2020-10-21 00:53:38 +0100
committerMounir Erhili2020-10-21 00:53:38 +0100
commit40941bae59ad906b51ae7df99f39a8064c9498c1 (patch)
treef0f089528fce0d4a3ebe6245e88c1d32ec9b7fad
parent54cf8e8ccba0b79dba8090462a1d2aa7f9869d35 (diff)
downloadaur-easyeda.tar.gz
first commit!
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD19
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2513149f24e..d0a66e0572c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = easyeda
pkgdesc = EasyEDA Desktop Client, A Simple and Powerful Electronic Circuit Design Tool
- pkgver = 2.0.0
- pkgrel = 0
+ pkgver = 6.4.7
+ pkgrel = 1
url = https://easyeda.com/page/download
arch = x86_64
license = custom
depends = gconf
options = !strip
- source = https://image.easyeda.com/files/easyeda-client-linux-x64.zip
- sha256sums = SKIP
+ source = https://image.easyeda.com/files/easyeda-linux-x64-6.4.7.zip
+ sha256sums = a50d9a3e9832fe67bcb8943d0096539dbd5be8846376ec9b15a9bab9b92d115a
pkgname = easyeda
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d082652c2bc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+*.zst
+*.deb
+*.gz
+*.xz
+git.sh
diff --git a/PKGBUILD b/PKGBUILD
index ec750b47ced2..4bbafc2b956a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-
-# Maintainer: Henri van de Munt <(firstname) @ gmail.com>
+# Maintainer: Mounir Erhili <mounirerhili@gmail.com>
pkgname=easyeda
-pkgver=2.0.0
-pkgrel=0
+pkgver=6.4.7
+pkgrel=1
pkgdesc="EasyEDA Desktop Client, A Simple and Powerful Electronic Circuit Design Tool"
arch=('x86_64')
license=(custom)
@@ -11,30 +10,30 @@ depends=(gconf)
url="https://easyeda.com/page/download"
options=('!strip')
-source=(https://image.easyeda.com/files/easyeda-client-linux-x64.zip)
-sha256sums=('SKIP')
+source=("https://image.easyeda.com/files/easyeda-linux-x64-${pkgver}.zip")
+sha256sums=('a50d9a3e9832fe67bcb8943d0096539dbd5be8846376ec9b15a9bab9b92d115a')
package() {
cd "${srcdir}"
install -d -m755 "${pkgdir}/opt/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/applications"
unzip -qqd ${pkgdir}/opt/${pkgname} easyeda-linux-x64.zip
- install -d -m755 "${pkgdir}/usr/share/applications"
+ chmod +x "${pkgdir}/opt/${pkgname}/easyeda"
-cat <<EOF > "${pkgdir}/usr/share/applications/easyeda-${pkgver}.desktop"
+ cat <<EOF > "${pkgdir}/usr/share/applications/easyeda.desktop"
[Desktop Entry]
Categories=Development;Electronics;
Comment=A Simple and Powerful Electronic Circuit Design Tool
Exec=/opt/easyeda/easyeda %f
Terminal=false
-Keywords=PCB;EasyEDA;
+Keywords=PCB;EASYEDA;EASY;EDA
GenericName=EasyEDA
Icon=/opt/easyeda/icon/128x128/easyeda.png
Name=EasyEDA ${pkgver}
Type=Application
Name[en_US]=EasyEDA
EOF
-
}