summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMadPhysicist2018-05-11 22:34:29 -0400
committerMadPhysicist2018-05-11 22:34:29 -0400
commit5145628067e117f86e59d7af542e236846bf0c88 (patch)
tree90a0aa15cb31476b8b3a47cf2fde36a627ccb6b3
parentb6ff4b789722002867b9d6b4d27d060e9b9c7c14 (diff)
downloadaur-easyloggingpp.tar.gz
Updated to 9.96.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4b841e84a08..060ccbfd223b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Thu Jun 29 03:51:13 UTC 2017
pkgbase = easyloggingpp
- pkgdesc = Robust, thread-safe lightweight single header only C++ logging library
- pkgver = 9.94.2
+ pkgdesc = Robust, thread-safe lightweight C++ logging library
+ pkgver = 9.96.4
pkgrel = 1
- url = https://github.com/easylogging/easyloggingpp
+ url = https://github.com/muflihun/easyloggingpp
arch = any
license = custom
optdepends = gcc: compiler that supports C++11
- source = https://github.com/easylogging/easyloggingpp/releases/download/v9.94.2/easyloggingpp_v9.94.2.tar.gz
- sha1sums = fbd4ac4d3c2b7a341c3d88c6e5d47a6cd79303d7
+ source = https://github.com/muflihun/easyloggingpp/archive/v9.96.4.tar.gz
+ sha1sums = 90ca248c7b04ee9856630680d1c91d8f7deccd89
pkgname = easyloggingpp
diff --git a/PKGBUILD b/PKGBUILD
index be984c30835c..2803ff083e3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer: MadPhysicist <jfoxrabinovitz at gmail dot com>
-_shortname=easylogging
-pkgname=${_shortname}pp
-pkgver=9.94.2
+pkgname=easyloggingpp
+pkgver=9.96.4
pkgrel=1
-pkgdesc='Robust, thread-safe lightweight single header only C++ logging library'
+pkgdesc='Robust, thread-safe lightweight C++ logging library'
arch=('any')
-url="https://github.com/${_shortname}/${pkgname}"
+url="https://github.com/muflihun/${pkgname}"
license=('custom')
groups=()
depends=()
@@ -18,13 +17,13 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/${_shortname}/${pkgname}/releases/download/v${pkgver}/${pkgname}_v${pkgver}.tar.gz")
+source=("https://github.com/muflihun/${pkgname}/archive/v${pkgver}.tar.gz")
noextract=()
-sha1sums=('fbd4ac4d3c2b7a341c3d88c6e5d47a6cd79303d7')
+sha1sums=('90ca248c7b04ee9856630680d1c91d8f7deccd89')
package() {
- install -Dm644 "${srcdir}/LICENCE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${srcdir}/easylogging++.h" "${pkgdir}/usr/include/easylogging++.h"
- install -Dm644 "${srcdir}/easylogging++.cc" "${pkgdir}/usr/include/easylogging++.cc"
- install -Dm644 "${srcdir}/CHANGELOG.txt" "${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/src/easylogging++.h" "${pkgdir}/usr/include/easylogging++.h"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/src/easylogging++.cc" "${pkgdir}/usr/include/easylogging++.cc"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/CHANGELOG.md" "${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG"
}