summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 17:24:05 +0100
committerBartłomiej Piotrowski2018-01-05 17:24:05 +0100
commitcc3983fec273734a68d40cc12aad6795af2806a6 (patch)
treea4b4b0aa5d5cb971b2250f9abcc7860512920435
downloadaur-ebizzy.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO15
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD31
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..060811371301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ebizzy
+ pkgdesc = Generate a workload resembling common web application server workloads
+ pkgver = 0.3
+ pkgrel = 3
+ url = http://ebizzy.sourceforge.net/
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = https://downloads.sourceforge.net/project/ebizzy/ebizzy/0.3/ebizzy-0.3.tar.gz
+ source = Makefile
+ sha1sums = e1a8afc36a68a4ea79ad5ec8f786a06d614d8ca5
+ sha1sums = 51da05091701e4a2ecc3be9ba638de235f596755
+
+pkgname = ebizzy
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..bb95f31770eb
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+LDLIBS = -lpthread
+
+ebizzy: ebizzy.c
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2042ff14d65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Masami Ichikawae <masami256@gmail.com>
+pkgname=ebizzy
+pkgver=0.3
+pkgrel=3
+pkgdesc='Generate a workload resembling common web application server workloads'
+arch=('x86_64')
+url="http://ebizzy.sourceforge.net/"
+license=('GPL2')
+depends=('glibc')
+source=('https://downloads.sourceforge.net/project/ebizzy/ebizzy/0.3/ebizzy-0.3.tar.gz'
+ Makefile)
+sha1sums=('e1a8afc36a68a4ea79ad5ec8f786a06d614d8ca5'
+ '51da05091701e4a2ecc3be9ba638de235f596755')
+
+build() {
+ cd $pkgname-$pkgver
+ make -f ../Makefile
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm 755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm 644 README "$pkgdir/usr/share/$pkgname/README"
+}
+
+check() {
+ cd $pkgname-$pkgver
+ ./ebizzy
+}