summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2020-10-01 18:45:57 +0200
committerTobias Borgert2020-10-01 18:45:57 +0200
commit759ab21115ad8e6e3a732c7e2a0771e186a5a37d (patch)
treec4c570c053a36bb14e891e9c9583e3a1906d80c2
parent431368bd8343db2a4b6d6172a90009ee9d71abc0 (diff)
downloadaur-759ab21115ad8e6e3a732c7e2a0771e186a5a37d.tar.gz
Update to v5.7.2
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD2
-rwxr-xr-xautoup.bash32
4 files changed, 36 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96715f712211..a7c5e7f0d016 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.7.1
+ pkgver = 5.7.2
pkgrel = 1
url = https://github.com/continental/ecal
arch = x86_64
diff --git a/.gitignore b/.gitignore
index c230193ac7b8..f596d26b0eb7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
src
pkg
+ecal
*.tar.gz
*.tar.xz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 38f60e834e49..84f0d9fa6d21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Borgert <tobias.borgert@gmail.com>
pkgname=ecal
-pkgver=5.7.1
+pkgver=5.7.2
pkgrel=1
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
diff --git a/autoup.bash b/autoup.bash
new file mode 100755
index 000000000000..b5326e8aadd5
--- /dev/null
+++ b/autoup.bash
@@ -0,0 +1,32 @@
+#!/bin/bash
+if [ -z "$1" ]; then
+ echo "You must specify the target version for the auto-update."
+ exit 1
+fi
+
+echo "Trying to auto-update this package to version ${1} ..."
+sed -ri 's/pkgver=([0-9]+\.[0-9]+\.[0-9]+\.{0,1}[0-9]*)/pkgver='"${1}"'/' PKGBUILD
+if [ "$?" -ne 0 ]; then
+ echo "Setting the version number in PKGBUILD failed."
+ exit 1
+fi
+
+updpkgsums
+if [ "$?" -ne 0 ]; then
+ echo "Updating the checksums failed."
+ exit 1
+fi
+
+makepkg --printsrcinfo > .SRCINFO
+if [ "$?" -ne 0 ]; then
+ echo "Recreating .SRCINFO failed."
+ exit 1
+fi
+
+makepkg -si
+if [ "$?" -ne 0 ]; then
+ echo "Building and installing the package failed."
+ exit 1
+fi
+
+echo "Autoupdate successful. Ready to add, commit and push the changes."