summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2023-05-11 09:41:32 +0200
committerTobias Borgert2023-05-11 09:41:32 +0200
commitb1925aec18ef1449e9b7aede4e35f94cd618bc55 (patch)
treede9ff356e461a243afd03b6d8f7580ac111c3c41
parent8632840fed107be5ae28af8fd920d189ada1c55f (diff)
downloadaur-b1925aec18ef1449e9b7aede4e35f94cd618bc55.tar.gz
Add patches to build with GCC 13. Upstream pull requests have been created
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--ecal-gcc13.patch35
-rw-r--r--termcolor-gcc13.patch21
4 files changed, 68 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59c073f1e892..a059fbe9011a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
pkgver = 5.11.4
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/eclipse-ecal/ecal
arch = x86_64
arch = armv7h
@@ -26,6 +26,10 @@ pkgbase = ecal
backup = etc/ecal/ecal.ini
backup = etc/ecal/ecaltime.ini
source = ecal-5.11.4.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.11.4/ecal-fat-source.tar.gz
+ source = ecal-gcc13.patch
+ source = termcolor-gcc13.patch
sha256sums = 48cc5522d64b01bd110cbfb97ed8990169b8a9713a424f78e231c139244b649b
+ sha256sums = 534801dd5ac16cfdf4a3a844ccb9a953c2852d013fd5c80c3d9bbe888583926c
+ sha256sums = df919e327f89688914e620a508facee6288528af815df1d581606375ece1a5b9
pkgname = ecal
diff --git a/PKGBUILD b/PKGBUILD
index 8e7bc2afe7fa..7be23ccf26dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ecal
pkgver=5.11.4
-pkgrel=3
+pkgrel=4
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
url="https://github.com/eclipse-ecal/ecal"
@@ -10,13 +10,15 @@ license=('Apache')
depends=('curl' 'protobuf' 'python' 'python-protobuf' 'qt5-base' 'qwt' 'hdf5' 'yaml-cpp')
makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'patchelf' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=()
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz")
-sha256sums=('48cc5522d64b01bd110cbfb97ed8990169b8a9713a424f78e231c139244b649b')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz" "ecal-gcc13.patch" "termcolor-gcc13.patch")
+sha256sums=('48cc5522d64b01bd110cbfb97ed8990169b8a9713a424f78e231c139244b649b'
+ '534801dd5ac16cfdf4a3a844ccb9a953c2852d013fd5c80c3d9bbe888583926c'
+ 'df919e327f89688914e620a508facee6288528af815df1d581606375ece1a5b9')
backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
prepare() {
-# patch --forward --strip=1 --input="../fineftp-server.filesystem.cpp.patch" "$pkgname/thirdparty/fineftp-server/fineftp-server/src/filesystem.cpp"
- :
+ patch --forward --strip=1 --input="ecal-gcc13.patch"
+ patch --forward --strip=1 --input="termcolor-gcc13.patch"
}
build() {
diff --git a/ecal-gcc13.patch b/ecal-gcc13.patch
new file mode 100644
index 000000000000..3cb7a5046ade
--- /dev/null
+++ b/ecal-gcc13.patch
@@ -0,0 +1,35 @@
+Subject: [PATCH] GCC13 compatibility: Explicitly include cstdint
+---
+Index: ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h
+IDEA additional info:
+Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
+<+>UTF-8
+===================================================================
+diff --git a/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h b/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h
+--- a/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h (revision 6b2843ad29597e7de06a6f80e99572006eeb097a)
++++ b/ecal/contrib/ecaltime/linuxptp/src/ecal_time_linuxptp.h (revision 044d473cfda4d70d57ac0a7c081cae0e2cc10ffb)
+@@ -21,6 +21,7 @@
+
+ #include <time.h>
+ #include <mutex>
++#include <string>
+
+ #define CLOCKFD 3
+ #define FD_TO_CLOCKID(fd) ((~(clockid_t) (fd) << 3) | CLOCKFD)
+Index: ecal/ecal/core/src/topic2mcast.h
+IDEA additional info:
+Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
+<+>UTF-8
+===================================================================
+diff --git a/ecal/ecal/core/src/topic2mcast.h b/ecal/ecal/core/src/topic2mcast.h
+--- a/ecal/ecal/core/src/topic2mcast.h (revision 6b2843ad29597e7de06a6f80e99572006eeb097a)
++++ b/ecal/ecal/core/src/topic2mcast.h (revision 044d473cfda4d70d57ac0a7c081cae0e2cc10ffb)
+@@ -23,6 +23,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <sstream>
+ #include <iostream>
+ #include <string>
+
diff --git a/termcolor-gcc13.patch b/termcolor-gcc13.patch
new file mode 100644
index 000000000000..b801733735c3
--- /dev/null
+++ b/termcolor-gcc13.patch
@@ -0,0 +1,21 @@
+Subject: [PATCH] GCC13 compatibility: Explicitly include cstdint
+
+See https://gcc.gnu.org/gcc-13/porting_to.html
+---
+Index: ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp
+IDEA additional info:
+Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
+<+>UTF-8
+===================================================================
+diff --git a/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp b/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp
+--- a/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp (revision b3cb0f365f8435588df7a6b12a82b2ac5fc1fe95)
++++ b/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp (date 1683614533931)
+@@ -13,6 +13,7 @@
+ #define TERMCOLOR_HPP_
+
+ #include <iostream>
++#include <cstdint>
+
+ // Detect target's platform and set some macros in order to wrap platform
+ // specific code this library depends on.
+