summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2024-05-29 18:59:57 +0200
committerTobias Borgert2024-05-29 18:59:57 +0200
commitfaad20e7f573d04184dc8c78195608ea7a00d2b9 (patch)
tree91fc9a2d1261d78be94a118448c42a6f3e7d5a1d
parent10a50c4978efcf6a1c148cc5456abe00af1a6f8a (diff)
downloadaur-faad20e7f573d04184dc8c78195608ea7a00d2b9.tar.gz
Update to v5.13.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xautoup.bash4
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d265b64de66f..64971fb8b4d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.13.0
+ pkgver = 5.13.1
pkgrel = 1
url = https://github.com/eclipse-ecal/ecal
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = ecal
depends = yaml-cpp
backup = etc/ecal/ecal.ini
backup = etc/ecal/ecaltime.ini
- source = ecal-5.13.0.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.13.0/ecal-fat-source.tar.gz
- sha256sums = 42444743f97a4e42b182e2ec0483459a3306a13c46a4af0b7bc113463850f924
+ source = ecal-5.13.1.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.13.1/ecal-fat-source.tar.gz
+ sha256sums = 2b636ae675a8e8693607bb62340574335effded783e2e3dda9f9218fc1c6d200
pkgname = ecal
diff --git a/PKGBUILD b/PKGBUILD
index c6627108e4b1..faf99a6d19e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Borgert <tobias (dot) borgert (at) gmail (dot) com>
pkgname=ecal
-pkgver=5.13.0
+pkgver=5.13.1
pkgrel=1
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
@@ -11,7 +11,7 @@ depends=('curl' 'protobuf' 'python' 'python-protobuf' 'qt5-base' 'qwt' 'hdf5' 'y
makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'patchelf' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=()
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz")
-sha256sums=('42444743f97a4e42b182e2ec0483459a3306a13c46a4af0b7bc113463850f924')
+sha256sums=('2b636ae675a8e8693607bb62340574335effded783e2e3dda9f9218fc1c6d200')
backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
prepare() {
diff --git a/autoup.bash b/autoup.bash
index 64cb4d276066..23ed3ff5c679 100755
--- a/autoup.bash
+++ b/autoup.bash
@@ -4,6 +4,10 @@ if [ -z "$1" ]; then
exit 1
fi
+echo "Cleaning up ..."
+rm -rf pkg src
+rm ecal-*
+
echo "Trying to auto-update this package to version ${1} ..."
sed -ri 's/pkgver=([0-9]+\.[0-9]+\.[0-9]+\.{0,1}[0-9]*)/pkgver='"${1}"'/' PKGBUILD
if [ "$?" -ne 0 ]; then