summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Latifi2022-06-16 13:06:17 +0200
committerFlorian Latifi2022-06-16 13:06:17 +0200
commit9845c3e256318f5f99d8ce8b8cd86da65a96a1d3 (patch)
tree62e97dcf55079e64ee3274bf7034944f5a6e7fd6
parent09b0037d9ac87ac44bed72e52f21d54318edf9ee (diff)
downloadaur-9845c3e256318f5f99d8ce8b8cd86da65a96a1d3.tar.gz
Update to 4.24
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
-rw-r--r--eclipse.desktop2
3 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91c07dda7957..1b26d9209ad0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eclipse-platform
pkgdesc = A minimal installation suitable for complete per-user customization with the built-in Eclipse package manager
- pkgver = 4.23
+ pkgver = 4.24
pkgrel = 1
url = https://www.eclipse.org
arch = x86_64
@@ -8,14 +8,14 @@ pkgbase = eclipse-platform
depends = java-runtime>=11
depends = unzip
depends = webkit2gtk
- provides = eclipse=4.23
+ provides = eclipse=4.24
conflicts = eclipse-common
options = !strip
- source = http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-4.23-202203080310/eclipse-platform-4.23-linux-gtk-x86_64.tar.gz&r=1
+ source = http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-4.24-202206070700/eclipse-platform-4.24-linux-gtk-x86_64.tar.gz&r=1
source = eclipse.sh
source = eclipse.desktop
- sha512sums = 004184344e405d7526211c2ff07a772c1c9f3edb86fc7be2a6a90ca2af8ae00fbc63b35909140cf5849ff33af8d92d1a613afaaf03fa5496a3a458b3e22c542e
+ sha512sums = 3cf805b62e945129080c4501198e2d0d57e76855f14d421122f7cc3955d5c48afe72218ad9d387a50ecaf617189d6aa822e9716bf7d5f935d023787370845500
sha512sums = 71393b01c2774654e1b3348ceedd6b110c7f1b26da93da40dac653ce2103a34997ec0e9e7fd4e977d869c149d19ef39f59738717cc6762e39b0bc0e7d53df4ac
- sha512sums = 6ea9f91f0704ec775aed2520737e4139ed7efcf89fd51220614e8fb8e8ce9e7460b8ff77d01519e5921f449752f60a1b36196c057e78a1906bfa4b2d346bdae2
+ sha512sums = 4155321f6a6f4671aa2753daa6466f4a06806b2d6fbc442066b75cbfd3ca3f45d61eb25bf9c662026fec7ffd307d30b3f1604792d0dfec4cca202656be627b97
pkgname = eclipse-platform
diff --git a/PKGBUILD b/PKGBUILD
index 273366f1d3cf..0b0b5c50eeb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Jesus Jerez <jhuss@archlinux.org.ve>
pkgname=eclipse-platform
-pkgver=4.23
-_pkgbuild=202203080310
+pkgver=4.24
+_pkgbuild=202206070700
pkgrel=1
pkgdesc="A minimal installation suitable for complete per-user customization with the built-in Eclipse package manager"
url="https://www.eclipse.org"
@@ -17,22 +17,26 @@ conflicts=("eclipse-common")
provides=("eclipse=$pkgver")
options=(!strip)
-source=("http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-${pkgver}-${_pkgbuild}/eclipse-platform-${pkgver}-linux-gtk-x86_64.tar.gz&r=1"
- "eclipse.sh"
- "eclipse.desktop")
+source=(
+ "http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-${pkgver}-${_pkgbuild}/eclipse-platform-${pkgver}-linux-gtk-x86_64.tar.gz&r=1"
+ "eclipse.sh"
+ "eclipse.desktop"
+)
-sha512sums=('004184344e405d7526211c2ff07a772c1c9f3edb86fc7be2a6a90ca2af8ae00fbc63b35909140cf5849ff33af8d92d1a613afaaf03fa5496a3a458b3e22c542e'
- '71393b01c2774654e1b3348ceedd6b110c7f1b26da93da40dac653ce2103a34997ec0e9e7fd4e977d869c149d19ef39f59738717cc6762e39b0bc0e7d53df4ac'
- '6ea9f91f0704ec775aed2520737e4139ed7efcf89fd51220614e8fb8e8ce9e7460b8ff77d01519e5921f449752f60a1b36196c057e78a1906bfa4b2d346bdae2')
+sha512sums=(
+ "3cf805b62e945129080c4501198e2d0d57e76855f14d421122f7cc3955d5c48afe72218ad9d387a50ecaf617189d6aa822e9716bf7d5f935d023787370845500"
+ "71393b01c2774654e1b3348ceedd6b110c7f1b26da93da40dac653ce2103a34997ec0e9e7fd4e977d869c149d19ef39f59738717cc6762e39b0bc0e7d53df4ac"
+ "4155321f6a6f4671aa2753daa6466f4a06806b2d6fbc442066b75cbfd3ca3f45d61eb25bf9c662026fec7ffd307d30b3f1604792d0dfec4cca202656be627b97"
+)
package() {
- install -d ${pkgdir}/usr/bin ${pkgdir}/usr/lib ${pkgdir}/usr/share/applications
- install -m755 "${srcdir}/eclipse.sh" "${pkgdir}/usr/bin/eclipse"
- install -Dm644 "${srcdir}/eclipse.desktop" "${pkgdir}/usr/share/applications/"
+ install -d ${pkgdir}/usr/bin ${pkgdir}/usr/lib ${pkgdir}/usr/share/applications
+ install -m755 "${srcdir}/eclipse.sh" "${pkgdir}/usr/bin/eclipse"
+ install -Dm644 "${srcdir}/eclipse.desktop" "${pkgdir}/usr/share/applications/"
- for _i in 16 32 48 256; do
- install -Dm644 "${srcdir}"/eclipse/plugins/org.eclipse.platform_*/eclipse${_i}.png "$pkgdir/usr/share/icons/hicolor/${_i}x${_i}/apps/eclipse.png"
- done
+ for _i in 16 32 48 256; do
+ install -Dm644 "${srcdir}"/eclipse/plugins/org.eclipse.platform_*/eclipse${_i}.png "$pkgdir/usr/share/icons/hicolor/${_i}x${_i}/apps/eclipse.png"
+ done
- mv "${srcdir}/eclipse" "${pkgdir}/usr/lib/"
+ mv "${srcdir}/eclipse" "${pkgdir}/usr/lib/"
}
diff --git a/eclipse.desktop b/eclipse.desktop
index c217d20fea6c..0ffb7d809b99 100644
--- a/eclipse.desktop
+++ b/eclipse.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Type=Application
-Version=4.23
+Version=4.24
Name=Eclipse
Comment=Open Development Platform
Exec=eclipse