summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Pedroni2015-07-21 11:40:10 +0200
committerEduardo Pedroni2015-07-21 11:40:10 +0200
commitd4d50315fe59d82eb1b308ff3207b797a293ceb2 (patch)
treeb34b8ade8bb942abcb6aa2cfb6a2d8ae84ae259e
parentbc870d3f2845566ac74924889d9e1824731b70fd (diff)
downloadaur-d4d50315fe59d82eb1b308ff3207b797a293ceb2.tar.gz
Update to Eclipse Mars (4.5)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0aeee21353a..cdf8eb3faa40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eclipse-platform
pkgdesc = A minimal installation suitable for complete per-user customization with the built-in Eclipse package manager
- pkgver = 4.4.2
- pkgrel = 2
+ pkgver = 4.5
+ pkgrel = 1
url = http://www.eclipse.org
install = eclipse-platform.install
arch = i686
@@ -13,14 +13,14 @@ pkgbase = eclipse-platform
depends = libwebkit
depends = libxtst
depends = hicolor-icon-theme
- provides = eclipse=4.4.2
+ provides = eclipse=4.5
conflicts = eclipse
options = !strip
- source = http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-4.4.2-201502041700/eclipse-platform-4.4.2-linux-gtk.tar.gz&r=1
+ source = http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/R-4.5-201506032000/eclipse-platform-4.5-linux-gtk.tar.gz&r=1
source = eclipse.sh
source = eclipse.svg
source = eclipse.desktop
- md5sums = ee01d78a2c8a85d59df8fc5275d73c35
+ md5sums = 558896a05f134eb2e6db179b83b93f55
md5sums = e07b2ccfc4689c288fd876a4beb8403d
md5sums = a0f93d5e697837d75911f5af9a386f19
md5sums = 45b39512f5e3e97fa078598a11245504
diff --git a/PKGBUILD b/PKGBUILD
index 728009ce5b45..14882c0bb3ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Jesus Jerez <jhuss@archlinux.org.ve>
pkgname=eclipse-platform
-pkgver=4.4.2
-_pkgbuild=201502041700
-pkgrel=2
+pkgver=4.5
+_pkgbuild=201506032000
+pkgrel=1
pkgdesc="A minimal installation suitable for complete per-user customization with the built-in Eclipse package manager"
url="http://www.eclipse.org"
arch=('i686' 'x86_64')
@@ -24,14 +24,14 @@ source=(
"eclipse.desktop"
)
-md5sums=('ee01d78a2c8a85d59df8fc5275d73c35'
+md5sums=('558896a05f134eb2e6db179b83b93f55'
'e07b2ccfc4689c288fd876a4beb8403d'
'a0f93d5e697837d75911f5af9a386f19'
'45b39512f5e3e97fa078598a11245504')
if [ "$CARCH" = "x86_64" ]; then
source[0]=${source/linux-gtk/linux-gtk-x86_64}
- md5sums[0]='e41938334858e5e6524e20d13d1e113f'
+ md5sums[0]='2242bc0ff1341a300fdd16b361fa6868'
fi
package() {
@@ -43,9 +43,9 @@ package() {
install -m644 "${srcdir}/eclipse.desktop" "${pkgdir}/usr/share/applications/"
mv "${srcdir}/eclipse" "${pkgdir}/usr/share/"
- ln -s /usr/share/eclipse/plugins/org.eclipse.platform_${pkgver}.v*/eclipse16.png "${pkgdir}/usr/share/icons/hicolor/16x16/apps/eclipse.png"
- ln -s /usr/share/eclipse/plugins/org.eclipse.platform_${pkgver}.v*/eclipse32.png "${pkgdir}/usr/share/icons/hicolor/32x32/apps/eclipse.png"
- ln -s /usr/share/eclipse/plugins/org.eclipse.platform_${pkgver}.v*/eclipse48.png "${pkgdir}/usr/share/icons/hicolor/48x48/apps/eclipse.png"
+ ln -s /usr/share/eclipse/plugins/org.eclipse.platform_${pkgver}*/eclipse16.png "${pkgdir}/usr/share/icons/hicolor/16x16/apps/eclipse.png"
+ ln -s /usr/share/eclipse/plugins/org.eclipse.platform_${pkgver}*/eclipse32.png "${pkgdir}/usr/share/icons/hicolor/32x32/apps/eclipse.png"
+ ln -s /usr/share/eclipse/plugins/org.eclipse.platform_${pkgver}*/eclipse48.png "${pkgdir}/usr/share/icons/hicolor/48x48/apps/eclipse.png"
install -Dm644 ${srcdir}/eclipse.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/eclipse.svg
}