summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2012-04-06 17:09:12 +0200
committerSven Schneider2012-04-06 17:09:12 +0200
commitb83d9f60a9efbad68aa61a995f27a537ac63afa9 (patch)
treecaa5b9dff7b4ae467f07bd73e24fba256437b114
downloadaur-eclipse-rtmtools.tar.gz
added initial set of pkgbuilds
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86963b72664e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = eclipse-rtmtools
+ pkgdesc = OpenRTM-aist tools to manipulate RT components in real-time using a graphical interface
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.openrtm.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = eclipse-emf
+ depends = eclipse-gef
+ optdepends = openrtm-aist: Compilation of C++ components
+ optdepends = openrtm-aist-java: Compilation of Java components
+ optdepends = openrtm-aist-python: Compilation of Python components
+ source = http://www.openrtm.org/pub/OpenRTM-aist/tools/1.0.0/rtmtools100release_en.zip
+ md5sums = e1051282f79dd8a2618ad993e92063ce
+
+pkgname = eclipse-rtmtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be765eba5aea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=eclipse-rtmtools
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="OpenRTM-aist tools to manipulate RT components in real-time using a graphical interface"
+arch=('i686' 'x86_64')
+url="http://www.openrtm.org"
+license=('GPL')
+depends=('eclipse-emf' 'eclipse-gef')
+optdepends=('openrtm-aist: Compilation of C++ components'
+ 'openrtm-aist-java: Compilation of Java components'
+ 'openrtm-aist-python: Compilation of Python components')
+source=(http://www.openrtm.org/pub/OpenRTM-aist/tools/1.0.0/rtmtools100release_en.zip)
+md5sums=('e1051282f79dd8a2618ad993e92063ce')
+
+build() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}
+