summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavi da Silva Böger2015-08-01 23:13:54 -0300
committerDavi da Silva Böger2015-08-01 23:13:54 -0300
commit3b44ee49b9ccd0c1113c4c3802392db89de8e151 (patch)
tree57fc9f830fb741c17f96169122c2213fc35367a8
downloadaur-3b44ee49b9ccd0c1113c4c3802392db89de8e151.tar.gz
Initial commit (copied from texlipse 1.5.0-6)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD49
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26064a0093b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlipse
+ pkgdesc = A plugin that adds LaTeX support to the Eclipse IDE
+ pkgver = 1.5.0
+ pkgrel = 6
+ url = http://texlipse.sourceforge.net/
+ arch = any
+ license = EPL
+ depends = eclipse>=3.5
+ depends = texlive-core
+ source = http://downloads.sourceforge.net/texlipse/texlipse_1.5.0%20src.zip
+ md5sums = db3de591e25d0ee3fbd03ce7d119fd15
+
+pkgname = texlipse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88cb50004a52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Davi da Silva Böger <dsboger@gmail.com>
+# Contributor: linuxSEAT <--put_my_name_here--@gmail.com>
+# Contributor: Robson R S Peixoto <robsonpeixoto@gmail.com>
+# Contributor: Piotr Beling <qwak@w8.pl>
+
+# added package(), adopted some conventions from
+# https://wiki.archlinux.org/index.php/Eclipse_plugin_package_guidelines
+# -- dsboger
+
+pkgname=texlipse
+pkgver=1.5.0
+pkgrel=6
+pkgdesc="A plugin that adds LaTeX support to the Eclipse IDE"
+url="http://texlipse.sourceforge.net/"
+depends=('eclipse>=3.5' 'texlive-core')
+arch=('any')
+license=('EPL')
+source=("http://downloads.sourceforge.net/texlipse/texlipse_${pkgver}%20src.zip")
+md5sums=('db3de591e25d0ee3fbd03ce7d119fd15')
+
+prepare() {
+ # remove features and plug-ins containing sources
+ rm -rf features/*.source_*
+ rm -rf plugins/*.source_*
+ # remove gz files
+ rm -rf plugins/*.pack.gz
+}
+
+package() {
+ _dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ # extract features (otherwise they are not visible in about dialog)
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 "${_plugin}" "${_dest}/${_plugin}"
+ done
+}
+