summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2016-10-29 13:40:54 +0200
committerCarsten Teibes2016-10-29 13:40:54 +0200
commitabaabd38ea583fd59c474ba1f62d9b3dcaabdc2c (patch)
tree71d4c61a4215905d537e0a5a263601a5a87a92fd
parent1921f79f51acac281582cacaebdc6c10c3e0545e (diff)
downloadaur-ecwolf-hg.tar.gz
[upd] fix dependencies, use custom sdl_mixer
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
-rw-r--r--ecwolf-datadirs.patch14
-rw-r--r--ecwolf.install5
4 files changed, 43 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f89332cdd77..422e8966f30d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecwolf-hg
pkgdesc = Advanced source port of "Wolfenstein 3D" and "Spear of Destiny" based on Wolf4SDL (development version)
- pkgver = 1.3.r6.bf7ee7fbc2b0
+ pkgver = 1.3.3.r3.f002d4054728
pkgrel = 1
url = http://maniacsvault.net/ecwolf
install = ecwolf.install
@@ -10,16 +10,23 @@ pkgbase = ecwolf-hg
license = custom: ID
makedepends = mercurial
makedepends = cmake
- depends = sdl_mixer
+ depends = sdl_net
+ depends = libvorbis
+ depends = flac
+ depends = opusfile
+ depends = libmikmod
+ depends = fluidsynth
depends = libjpeg
depends = gtk2
optdepends = wolf3d-shareware: Demo version of Wolfenstein 3D
provides = ecwolf
conflicts = ecwolf
source = hg+https://bitbucket.org/Blzut3/ecwolf
+ source = hg+https://bitbucket.org/Blzut3/sdl_mixer-for-ecwolf
source = ecwolf-datadirs.patch
sha256sums = SKIP
- sha256sums = f99391f9139fc796dc69b081132ca76ce2ecb16978b29a1e864969946c15283c
+ sha256sums = SKIP
+ sha256sums = 46d59c0a25e34e32fc73cef60c146103cb3e57bc7c904c048371c3eccb89e183
pkgname = ecwolf-hg
diff --git a/PKGBUILD b/PKGBUILD
index 283f433ed739..8e76f80201ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=ecwolf-hg
-pkgver=1.3.r6.bf7ee7fbc2b0
+pkgver=1.3.3.r3.f002d4054728
pkgrel=1
pkgdesc='Advanced source port of "Wolfenstein 3D" and "Spear of Destiny" based on Wolf4SDL (development version)'
arch=('i686' 'x86_64')
@@ -9,36 +9,46 @@ url="http://maniacsvault.net/ecwolf"
license=('GPL' 'custom: ID')
provides=('ecwolf')
conflicts=('ecwolf')
-depends=('sdl_mixer' 'libjpeg' 'gtk2')
+depends=('sdl_net' 'libvorbis' 'flac' 'opusfile' 'libmikmod' 'fluidsynth' 'libjpeg' 'gtk2')
makedepends=('mercurial' 'cmake')
optdepends=('wolf3d-shareware: Demo version of Wolfenstein 3D')
install=ecwolf.install
source=("hg+https://bitbucket.org/Blzut3/ecwolf"
+ "hg+https://bitbucket.org/Blzut3/sdl_mixer-for-ecwolf"
"ecwolf-datadirs.patch")
sha256sums=('SKIP'
- 'f99391f9139fc796dc69b081132ca76ce2ecb16978b29a1e864969946c15283c')
+ 'SKIP'
+ '46d59c0a25e34e32fc73cef60c146103cb3e57bc7c904c048371c3eccb89e183')
pkgver() {
cd ecwolf
- _tag=$(hg tags -q | sort -r | grep "^[0-9]\.[0-9]" | head -n1)
- _commits=$(hg log --template "{node}\n" -r $_tag:tip | wc -l)
- printf "%s.r%s.%s" "$_tag" "$_commits" "$(hg identify -i)"
+ local _tag=$(hg tags -q | sort -r | grep "^[0-9]\.[0-9]" | head -n1)
+ local _commits=$(hg log --template "{node}\n" -r $_tag:tip | wc -l)
+ local _hash=$(hg identify -i | sed "s/+//")
+ printf "%s.r%s.%s" "$_tag" "$_commits" "$_hash"
}
prepare() {
- # reset build folder
- rm -rf build
- mkdir build
+ # reset build folders
+ rm -rf build mixer-build
+ mkdir build mixer-build
# data dir hack (using a patch, so we can see it fail, when the source has changed)
- patch -Np0 <ecwolf-datadirs.patch
+ patch -Np0 < ecwolf-datadirs.patch
}
build() {
- cd build
+ msg2 "Building custom SDL_mixer..."
+ cd mixer-build
+ cmake ../sdl_mixer-for-ecwolf
+ make
- # build patch utility and enable gpl licensed opl emulator
- cmake ../ecwolf -DBUILD_PATCHUTIL=ON -DGPL=ON
+ msg2 "Building ecwolf..."
+ cd ../build
+ # build patch utility, enable gpl licensed opl emulator and force custom SDL2_mixer with dependency libraries
+ cmake ../ecwolf -DBUILD_PATCHUTIL=ON -DGPL=ON \
+ -DSDLMIXER_INCLUDE_DIR="$srcdir/sdl_mixer-for-ecwolf" \
+ -DSDLMIXER_LIBRARY="$srcdir/mixer-build/libSDL_mixer.a;-lfluidsynth;-lvorbisfile;-lvorbis;-lopusfile;-lopus;-lFLAC;-lmikmod;-logg"
make
}
diff --git a/ecwolf-datadirs.patch b/ecwolf-datadirs.patch
index 8e0d0fefda76..1f19514f0e5a 100644
--- a/ecwolf-datadirs.patch
+++ b/ecwolf-datadirs.patch
@@ -1,7 +1,7 @@
-diff -Naur ecwolf.old/src/wl_iwad.cpp ecwolf/src/wl_iwad.cpp
---- ecwolf.old/src/wl_iwad.cpp 2014-05-25 09:17:58.000000000 +0200
-+++ ecwolf/src/wl_iwad.cpp 2014-06-04 11:24:40.778863092 +0200
-@@ -430,7 +430,7 @@
+diff -Naur -x.hg ecwolf.old/src/wl_iwad.cpp ecwolf/src/wl_iwad.cpp
+--- ecwolf.old/src/wl_iwad.cpp 2016-10-29 12:08:37.510265126 +0200
++++ ecwolf/src/wl_iwad.cpp 2016-10-29 13:09:29.469624116 +0200
+@@ -481,7 +481,7 @@
int defaultIWad = config.GetSetting("DefaultIWad")->GetInteger();
bool useProgdir = false;
@@ -10,7 +10,7 @@ diff -Naur ecwolf.old/src/wl_iwad.cpp ecwolf/src/wl_iwad.cpp
if(!datawadRes)
{
useProgdir = true;
-@@ -493,7 +493,7 @@
+@@ -544,7 +544,7 @@
}
while(split != 0);
@@ -19,12 +19,12 @@ diff -Naur ecwolf.old/src/wl_iwad.cpp ecwolf/src/wl_iwad.cpp
// Look for a steam install. (Basically from ZDoom)
{
-@@ -558,7 +558,7 @@
+@@ -639,7 +639,7 @@
selectedGame = &iwadTypes[base.Type];
if(!useProgdir)
- wadfiles.Push(datawad);
+ wadfiles.Push("/usr/share/ecwolf/ecwolf.pk3");
else
- wadfiles.Push(progdir + "/" + datawad);
+ wadfiles.Push(progdir + PATH_SEPARATOR + datawad);
for(unsigned int i = 0;i < base.Path.Size();++i)
diff --git a/ecwolf.install b/ecwolf.install
index f3cf9709a491..e3f81c29d024 100644
--- a/ecwolf.install
+++ b/ecwolf.install
@@ -1,5 +1,6 @@
post_install() {
- echo "You need 'Wolfenstein 3D' or 'Spear of Destiny' data files under '~/.config/ecwolf'."
- echo "You can get the shareware versions here: http://maniacsvault.net/ecwolf/download.php"
+ echo " => You need 'Wolfenstein 3D' or 'Spear of Destiny' data files, put them under"
+ echo " '~/.config/ecwolf'. You can get the shareware versions here:"
+ echo " http://maniacsvault.net/ecwolf/download.php"
}