summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brodsky2022-01-24 19:19:08 +0100
committerKevin Brodsky2022-01-24 19:19:08 +0100
commitff8d4ce2bba509df1ce8af87e445b0bb25bb195a (patch)
tree18adf3dc942990e0a4f414ab74221802b3f35e40
parentb130d09a6fd00cf9b2bf4e31ce73b08dab162313 (diff)
downloadaur-edgar-git.tar.gz
Update to latest from git
The build system is now meson. Also get rid of the .install file, as module-dbus-protocol is already loaded by default in /etc/pulse/default.pa.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
-rw-r--r--edgar-git.install22
3 files changed, 11 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8982b8e8488f..49e8d9854d57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = edgar-git
pkgdesc = Load Python gadgets in Enlightenment
- pkgver = r49.63b9e57
+ pkgver = r72.250957a
pkgrel = 1
url = https://phab.enlightenment.org/w/emodules/edgar/
- install = edgar-git.install
arch = x86_64
arch = i686
license = GPL3
license = LGPL3
makedepends = git
- depends = enlightenment>=0.17
- depends = python>=3.2
+ makedepends = meson
+ depends = enlightenment>=0.24
+ depends = python>=3.5
depends = python-efl>=1.11
depends = python-dbus
depends = python-psutil
@@ -20,4 +20,3 @@ pkgbase = edgar-git
md5sums = SKIP
pkgname = edgar-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f9958ee0e715..c8ceb4b27b95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,30 @@
_pkgname=edgar
pkgname=edgar-git
-pkgver=r49.63b9e57
+pkgver=r72.250957a
pkgrel=1
pkgdesc="Load Python gadgets in Enlightenment"
arch=('x86_64' 'i686')
url="https://phab.enlightenment.org/w/emodules/edgar/"
license=('GPL3' 'LGPL3')
-depends=('enlightenment>=0.17' 'python>=3.2' 'python-efl>=1.11' 'python-dbus'
+depends=('enlightenment>=0.24' 'python>=3.5' 'python-efl>=1.11' 'python-dbus'
'python-psutil')
-makedepends=('git')
+makedepends=('git' 'meson')
provides=(edgar)
conflicts=(edgar)
-install=edgar-git.install
source=("git+https://git.enlightenment.org/enlightenment/modules/$_pkgname.git")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
- cd "$srcdir/$_pkgname"
- ./autogen.sh --prefix=/usr --sysconfdir=/etc
- make -j$(nproc)
+ arch-meson $_pkgname build
+ meson compile -C build
}
package() {
- cd "$srcdir/$_pkgname"
-
- # The module
- make DESTDIR="$pkgdir/" install
-
- # Shipped gadgets
- cd GADGETS
- for gadget in *; do
- make -C "$gadget" prefix="$pkgdir/usr/lib" install
- done
+ DESTDIR="$pkgdir" meson install -C build
}
diff --git a/edgar-git.install b/edgar-git.install
deleted file mode 100644
index f689d4e5b462..000000000000
--- a/edgar-git.install
+++ /dev/null
@@ -1,22 +0,0 @@
-## arg 1: the new package version
-post_install() {
- echo "You needed to load the PulseAudio DBus module for audio gadget to work."
- echo "Run this command to load the dbus module:"
- echo -e "\tpactl load-module module-dbus-protocol"
- echo "You may consider adding the following line to /etc/pulse/default.pa"
- echo -e "\tload-module module-dbus-protocol"
- echo "for a persistent configuration"
-}
-
-## arg 1: the new package version
-## arg 2: the old package version
-post_upgrade() {
- post_install "$1"
-}
-
-## arg 1: the old package version
-post_remove() {
- echo "If you don't needed PulseAudio DBus module anymore (used by this audio gadget),"
- echo "consider remove the following line in /etc/pulse/default.pa:"
- echo -e "\tload-module module-dbus-protocol"
-}