summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2015-07-10 11:13:35 +0500
committerDmitry Kharitonov2015-07-10 11:13:35 +0500
commitfeb122b663ecf3c1c82bf8c3fe284289d7dd3fb8 (patch)
tree315055cf9466dd72c55cdf0494ad39593dc4ef59
downloadaur-feb122b663ecf3c1c82bf8c3fe284289d7dd3fb8.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0e93e0ceee5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = edx-downloader-git
+ pkgdesc = A simple tool to download video lectures from edx.org.
+ pkgver = latest
+ pkgrel = 2
+ url = https://github.com/shk3/edx-downloader
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python
+ depends = python-beautifulsoup4
+ depends = youtube-dl
+ depends = python-six
+ depends = python-html5lib
+ depends = pandoc-bin
+ provides = edx-downloader
+ conflicts = edx-downloader
+
+pkgname = edx-downloader-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c41cf98cd2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Enrico Bacis <enrico.bacis@gmail.com>
+pkgname=edx-downloader-git
+pkgver=latest
+pkgrel=2
+pkgdesc='A simple tool to download video lectures from edx.org.'
+arch=('any')
+url='https://github.com/shk3/edx-downloader'
+license=('unknown')
+makedepends=('git')
+depends=('python' 'python-beautifulsoup4' 'youtube-dl' 'python-six' 'python-html5lib' 'pandoc-bin')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+# it downloads 20MB of useless pack files
+#source=("${pkgname%-git}::git://github.com/shk3/edx-downloader.git")
+#md5sums=('SKIP')
+
+pkgver() {
+ msg "Downloading git repository..."
+ git clone https://github.com/shk3/edx-downloader.git "$srcdir/${pkgname%-git}"
+
+ cd "$srcdir/${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ #install -D -m 755 edx-dl.py "${pkgdir}/usr/bin/edx-downloader"
+ pandoc --from=markdown --to=rst --output=README.rst README.md
+ python setup.py install --root="$pkgdir/" --optimize=1
+}