summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Rose2020-10-21 22:10:59 +1100
committerEden Rose2020-10-21 22:10:59 +1100
commite6dbeda7413a26c2b88073ae98dbee26bc6d7192 (patch)
tree8de3875a9b0e6f793b1caf8ff6e6978f9aff8414
downloadaur-e6dbeda7413a26c2b88073ae98dbee26bc6d7192.tar.gz
Initial: Needs work, depends and looots of testing!
-rw-r--r--.SRCINFO90
-rw-r--r--PKGBUILD107
2 files changed, 197 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cabce2bddda2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,90 @@
+pkgbase = efl-full-git
+ pkgdesc = Enlightenment Foundation Libraries - Full Development version (All optional settings enabled)
+ pkgver = 1.25.99.66347.gd6a6dd54a1
+ pkgrel = 1
+ url = http://www.enlightenment.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = LGPL2.1
+ license = GPL2
+ license = MIT
+ license = custom
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = pkgconf
+ makedepends = gcc
+ makedepends = binutils
+ makedepends = fakeroot
+ makedepends = procps-ng
+ makedepends = ccache
+ depends = curl
+ depends = fontconfig
+ depends = fribidi
+ depends = harfbuzz
+ depends = gst-plugins-base-libs
+ depends = lua52
+ depends = libgl
+ depends = libinput
+ depends = libpulse
+ depends = libsndfile
+ depends = libspectre
+ depends = libraw
+ depends = librsvg
+ depends = libwebp
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxinerama
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxss
+ depends = libunwind
+ depends = mesa
+ depends = poppler
+ depends = openjpeg2
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libtiff
+ depends = giflib
+ depends = lz4
+ depends = zlib
+ depends = systemd-libs
+ depends = openssl
+ depends = glibc
+ depends = libutil-linux
+ depends = dbus
+ depends = shared-mime-info
+ depends = mailcap
+ depends = ttf-font
+ depends = scim
+ depends = wayland
+ depends = wayland-protocols
+ depends = libxkbcommon-x11
+ depends = pulseaudio
+ optdepends = gst-plugins-base: Video and thumbnail codecs
+ optdepends = gst-plugins-good: Video and thumbnail codecs
+ optdepends = gst-plugins-bad: Video and thumbnail codecs
+ optdepends = gst-plugins-ugly: Video and thumbnail codecs
+ optdepends = gst-libav: Video and thumbnails with ffmpeg/libav
+ optdepends = libreoffice: Office document thumbnails
+ provides = efl=1.25.99.66347.gd6a6dd54a1
+ provides = elementary=1.25.99.66347.gd6a6dd54a1
+ provides = elementary-git=1.25.99.66347.gd6a6dd54a1
+ provides = evas_generic_loaders=1.25.99.66347.gd6a6dd54a1
+ provides = ephysics=1.25.99.66347.gd6a6dd54a1
+ provides = ephysics-git=1.25.99.66347.gd6a6dd54a1
+ conflicts = efl
+ conflicts = elementary
+ conflicts = elementary-git
+ conflicts = elementary_test
+ conflicts = elementary_test-git
+ conflicts = evas_generic_loaders
+ conflicts = evas_generic_loaders-git
+ options = debug
+ options = ccache
+ source = git+https://git.enlightenment.org/core/efl.git
+ sha256sums = SKIP
+
+pkgname = efl-full-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9876498f1442
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,107 @@
+# CLONED FROM 'efl-git' - https://aur.archlinux.org/packages/efl-git/
+#
+# Maintainer EndlessEden < TODO >
+#
+# NOTE: This is a <WIP> | Dragons ahead...
+#
+
+_pkgname=efl
+pkgname=$_pkgname-full-git
+pkgver=1.25.99.66347.gd6a6dd54a1
+pkgrel=1
+pkgdesc="Enlightenment Foundation Libraries - Full Development version (All optional settings enabled)"
+arch=('i686' 'x86_64')
+url="http://www.enlightenment.org"
+license=('BSD' 'LGPL2.1' 'GPL2' 'MIT' 'custom')
+depends=('curl' 'fontconfig' 'fribidi' 'harfbuzz'
+ 'gst-plugins-base-libs' 'lua52' 'libgl' 'libinput'
+ 'libpulse' 'libsndfile' 'libspectre' 'libraw' 'librsvg' 'libwebp'
+ 'libxcomposite' 'libxcursor' 'libxinerama' 'libxkbcommon' 'libxrandr'
+ 'libxss' 'libunwind' 'mesa' 'poppler' 'openjpeg2' 'libjpeg-turbo'
+ 'libpng' 'libtiff' 'giflib' 'lz4' 'zlib' 'systemd-libs' 'openssl'
+ 'glibc' 'libutil-linux' 'dbus'
+ 'shared-mime-info' 'mailcap' 'ttf-font' 'scim'
+ 'wayland' 'wayland-protocols' 'libxkbcommon-x11'
+ 'pulseaudio')
+makedepends=('git' 'meson' 'ninja' 'pkgconf' 'gcc' 'binutils' 'fakeroot' 'procps-ng' 'ccache')
+optdepends=('gst-plugins-base: Video and thumbnail codecs'
+ 'gst-plugins-good: Video and thumbnail codecs'
+ 'gst-plugins-bad: Video and thumbnail codecs'
+ 'gst-plugins-ugly: Video and thumbnail codecs'
+ 'gst-libav: Video and thumbnails with ffmpeg/libav'
+ 'libreoffice: Office document thumbnails')
+provides=("$_pkgname=$pkgver" elementary{,-git}=$pkgver "evas_generic_loaders=$pkgver" ephysics{,-git}=$pkgver)
+conflicts=("$_pkgname" elementary{,-git} elementary_test{,-git} evas_generic_loaders{,-git})
+options=('debug' 'ccache')
+source=("git+https://git.enlightenment.org/core/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ local v_ver=$(grep version meson.build | head -1 | sed s/version//g | tr ":'," " " | awk '{print $1}')
+
+ printf "%s.%s.g%s" "$v_ver" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+
+ # fix -mfpu= flags that break a build e.g. for neon on armv7 due to
+ # basically makepkg.conf being "bad' with default CFLAGS having
+ # -mfpu=vfpv3-d16
+ export CFLAGS=`echo -n $CFLAGS | sed 's/-mfpu=vfpv3-d16/-mfpu=neon-vfpv4/g'`
+ export CFLAGS="$CFLAGS -fvisibility=hidden"
+ export CXXFLAGS="$CXXFLAGS -fvisibility=hidden"
+
+ # this is so this will build on ALARM on a raspberry pi with 1GB RAM...
+ # and ninja doesnt do MAKEFLAKGS or NINJAFLAGS thus have to pass -j N
+ MEM=`free -m | head -2 | tail -1 | awk '{printf("%s", $7);}'`
+ if test "$MEM" -lt 300; then MEM=300; fi
+ J=`expr $MEM / 300`
+ CPUS=`echo /sys/devices/system/cpu/cpu[0-9]* | wc -w`
+ if test "$J" -gt $CPUS; then J=$CPUS; fi
+ if test "$J" -lt 1; then J=1; fi
+ echo "Free Mem: $MEM M, using $J threads for build"
+
+ rm -rf build
+ meson --prefix=/usr
+ -Dfb=true \
+ -Ddrm=true \
+ -Davahi=true \
+ -Dx11=true \
+ -Dsdl=true \
+ -Dbuffer=true \
+ -Dwl=true \
+ -Dwl-deprecated=true \
+ -Ddrm-deprecated=true \
+ -Dxpresent=true \
+ -Dtslib=true \
+ -Dopengl=full \
+ -Dphysics=true \
+ -Dglib=true \
+ -Decore-imf-loaders-disabler='' \
+ -Dbindings='cxx', 'lua', 'mono' \
+ -Dmono-beta=true \
+ -Dwindows-version='win10' \
+ -Dpixman=true \
+ -Dhyphen=true \
+ -Dvnc-server=true \
+ -Delua=true \
+ -Dnetwork-backend=connman \
+ -Dlua-interpreter=lua \
+ -Dbindings= \
+ -Dbuild-examples=false \
+ -Dbuild-tests=false \
+ . build
+ ninja -j $J -C build
+}
+
+package() {
+ cd $_pkgname
+
+ DESTDIR="$pkgdir" ninja -C build install
+
+ install -Dm644 -t "$pkgdir/usr/share/doc/$_pkgname/" ChangeLog NEWS README
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" AUTHORS COMPLIANCE COPYING COPYING.images licenses/COPYING.{BSD,SMALL}
+}