summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFedor Piecka2022-10-20 16:48:33 +0200
committerFedor Piecka2022-10-20 16:48:33 +0200
commit5b4b2dabde346ff6b7f27d318d487c491ecdc0e8 (patch)
tree3e6075e310d05ad46da853c0fbbb7206b9f87914
parentf7515c629792bc2aac409395a60c8a4706ac8eaf (diff)
downloadaur-5b4b2dabde346ff6b7f27d318d487c491ecdc0e8.tar.gz
Upgrade to 4.1 based on appimage
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD47
2 files changed, 40 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 566fa9951148..6a888ed387bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = eidklient
pkgdesc = Slovak eID Client
- pkgver = 3.7.0
- pkgrel = 2
+ pkgver = 4.1
+ pkgrel = 1
url = https://www.slovensko.sk/
install = eidklient.install
arch = i686
arch = x86_64
license = custom
options = !strip
- source_i686 = https://eidas.minv.sk/TCTokenService/download/linux/debian/Aplikacia_pre_eID_i386_debian.tar.gz
+ source = https://eidas.minv.sk/downloadservice/eidklient/linux//eID_klient_release_notes.txt
+ md5sums = SKIP
+ source_i686 = https://eidas.minv.sk/downloadservice/eidklient/linux//eID_klient-x86_64.AppImage
md5sums_i686 = SKIP
- source_x86_64 = https://eidas.minv.sk/TCTokenService/download/linux/debian/Aplikacia_pre_eID_amd64_debian.tar.gz
+ source_x86_64 = https://eidas.minv.sk/downloadservice/eidklient/linux//eID_klient-x86_64.AppImage
md5sums_x86_64 = SKIP
pkgname = eidklient
- depends = glibc
depends = pcsclite
depends = ccid
+ depends = squashfuse
optdepends = disig-web-signer: online certificates update support
diff --git a/PKGBUILD b/PKGBUILD
index f46238b449a9..72ad2c670e14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,52 @@
# Maintainer: Fedor Piecka <teplavoda at gmail dot com>
pkgname=eidklient
-pkgver=3.7.0
-pkgrel=2
+pkgver=4.1
+pkgrel=1
pkgdesc="Slovak eID Client"
arch=('i686' 'x86_64')
url="https://www.slovensko.sk/"
license=('custom')
-source_i686=('https://eidas.minv.sk/TCTokenService/download/linux/debian/Aplikacia_pre_eID_i386_debian.tar.gz')
-source_x86_64=('https://eidas.minv.sk/TCTokenService/download/linux/debian/Aplikacia_pre_eID_amd64_debian.tar.gz')
+_upstream_arch=
+[[ "$CARCH" == "x86_64" ]] && _upstream_arch="x86_64"
+[[ "$CARCH" == "i686" ]] && _upstream_arch="i386"
+_appimage="eID_klient-${_upstream_arch}.AppImage"
+_url="https://eidas.minv.sk/downloadservice/eidklient/linux/"
+source=("${_url}/eID_klient_release_notes.txt")
+source_i686=("${_url}/${_appimage}")
+source_x86_64=("${_url}/${_appimage}")
+# upstream update would break this PKGBUILD if we used integrity checks
+md5sums=('SKIP')
md5sums_i686=('SKIP')
md5sums_x86_64=('SKIP')
options=("!strip")
install=eidklient.install
-# Upstream uses Debian architecture naming convention. Let's prepare a variable for that.
-upstream_arch=
-[[ "$CARCH" == "x86_64" ]] && upstream_arch="amd64"
-[[ "$CARCH" == "i686" ]] && upstream_arch="i386"
-
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
pkgver() {
- # Match Debian package version
- ar p ${srcdir}/Aplikacia_pre_eID_${upstream_arch}_debian.deb control.tar.gz | tar -Oxz ./control | grep ^Version: | cut -f2 -d" " | tr -d '[:space:]'
+ # Match version from upstream release notes
+ cat eID_klient_release_notes.txt | grep "verzia" | head -n1 | sed 's/^.*verzia \([0-9.]*\).*/\1/'
}
package() {
- depends=("glibc" "pcsclite" "ccid" )
- optdepends=('disig-web-signer: online certificates update support')
+ depends=( "pcsclite" "ccid" "squashfuse" )
+ optdepends=('disig-web-signer: online certificates update support')
+
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Icons + desktop file
+ tar -x -C "${pkgdir}/usr" -f "${srcdir}/squashfs-root/share.tar"
- ar p ${srcdir}/Aplikacia_pre_eID_${upstream_arch}_debian.deb data.tar.xz | tar -xJ -C "${pkgdir}"
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E "s|Exec=[^ ]*|Exec=env DESKTOPINTEGRATION=false /usr/bin/${pkgname}|"\
+ "${pkgdir}/usr/share/applications/eID_klient.desktop"
}