summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFedor Piecka2019-03-27 21:41:08 +0100
committerFedor Piecka2019-03-27 21:41:08 +0100
commita5e4c93d4604b8f1770f286546941bed4535487b (patch)
tree8e21e80bde94a69c6d0a2e4daac7a61f397eea4a
parent93a90934799b7b4da3de2edf60d7edb1860df4e1 (diff)
downloadaur-a5e4c93d4604b8f1770f286546941bed4535487b.tar.gz
Included install script which notifies the user to enable pcscd.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--eidklient.install24
3 files changed, 28 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc9894cb0d24..2a319981596e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = eidklient
pkgdesc = Slovak eID Client
pkgver = 3.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.slovensko.sk/
+ install = eidklient.install
arch = i686
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 2ca5cae6deb5..ceb7f1d69d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=eidklient
pkgver=3.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Slovak eID Client"
arch=('i686' 'x86_64')
url="https://www.slovensko.sk/"
@@ -12,6 +12,7 @@ source_x86_64=('https://eidas.minv.sk/TCTokenService/download/linux/debian/Aplik
md5sums_i686=('SKIP')
md5sums_x86_64=('SKIP')
options=("!strip")
+install=eidklient.install
# Upstream uses Debian architecture naming convention. Let's prepare a variable for that.
upstream_arch=
diff --git a/eidklient.install b/eidklient.install
new file mode 100644
index 000000000000..0814a0a4ba89
--- /dev/null
+++ b/eidklient.install
@@ -0,0 +1,24 @@
+checkpcscd() {
+ if [ "`systemctl is-enabled pcscd.socket`" != "enabled" -a \
+ "`systemctl is-enabled pcscd.service`" != "enabled" ] ; then
+
+ cat <<-EOF
+ >>> pcscd is required for a proper function of eidklient
+ >>> You can enable it by issuing:
+ >>>
+ >>> sudo systemctl enable pcscd.socket && sudo systemctl start pcscd.socket
+ EOF
+ fi
+}
+
+## arg 1: the new package version
+post_install() {
+ checkpcscd
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ checkpcscd
+}
+