summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFedor Piecka2022-10-20 17:59:33 +0200
committerFedor Piecka2022-10-20 17:59:43 +0200
commitfa4f6109c960c75fbed979a008c611c2395a110d (patch)
tree6133f3afdeb49dab77ee016add0f6d4db586bb76
parent5b4b2dabde346ff6b7f27d318d487c491ecdc0e8 (diff)
downloadaur-fa4f6109c960c75fbed979a008c611c2395a110d.tar.gz
Improve PKGBUILD
* Lower the number of dependencies (fuse2 is enough, squashfuse is not required) * Leaner code
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a888ed387bd..9a50fc7fa2eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = eidklient
pkgdesc = Slovak eID Client
pkgver = 4.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.slovensko.sk/
install = eidklient.install
arch = i686
arch = x86_64
license = custom
options = !strip
- source = https://eidas.minv.sk/downloadservice/eidklient/linux//eID_klient_release_notes.txt
+ source = https://eidas.minv.sk/downloadservice/eidklient/linux/eID_klient_release_notes.txt
md5sums = SKIP
- source_i686 = https://eidas.minv.sk/downloadservice/eidklient/linux//eID_klient-x86_64.AppImage
+ source_i686 = https://eidas.minv.sk/downloadservice/eidklient/linux/eID_klient-x86_64.AppImage
md5sums_i686 = SKIP
- source_x86_64 = https://eidas.minv.sk/downloadservice/eidklient/linux//eID_klient-x86_64.AppImage
+ source_x86_64 = https://eidas.minv.sk/downloadservice/eidklient/linux/eID_klient-x86_64.AppImage
md5sums_x86_64 = SKIP
pkgname = eidklient
depends = pcsclite
depends = ccid
- depends = squashfuse
+ depends = fuse2
optdepends = disig-web-signer: online certificates update support
diff --git a/PKGBUILD b/PKGBUILD
index 72ad2c670e14..d9f1c4958981 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=eidklient
pkgver=4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Slovak eID Client"
arch=('i686' 'x86_64')
url="https://www.slovensko.sk/"
@@ -11,7 +11,8 @@ _upstream_arch=
[[ "$CARCH" == "x86_64" ]] && _upstream_arch="x86_64"
[[ "$CARCH" == "i686" ]] && _upstream_arch="i386"
_appimage="eID_klient-${_upstream_arch}.AppImage"
-_url="https://eidas.minv.sk/downloadservice/eidklient/linux/"
+_url="https://eidas.minv.sk/downloadservice/eidklient/linux"
+# alternative version URI: https://eidas.minv.sk/TCTokenService/download/linux/ubuntu/version.txt
source=("${_url}/eID_klient_release_notes.txt")
source_i686=("${_url}/${_appimage}")
source_x86_64=("${_url}/${_appimage}")
@@ -28,12 +29,12 @@ prepare() {
}
pkgver() {
- # Match version from upstream release notes
- cat eID_klient_release_notes.txt | grep "verzia" | head -n1 | sed 's/^.*verzia \([0-9.]*\).*/\1/'
+ # Match version from upstream release notes
+ grep -Pom1 'verzia \K[\d.]+' eID_klient_release_notes.txt
}
package() {
- depends=( "pcsclite" "ccid" "squashfuse" )
+ depends=( "pcsclite" "ccid" "fuse2" )
optdepends=('disig-web-signer: online certificates update support')
# AppImage