summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Pronko2022-05-01 12:26:16 +0300
committerPlaton Pronko2022-05-01 12:26:16 +0300
commit2c11446cecd0b12db69eeedbfd400218d878df6c (patch)
treefffcf77f2d6fe19e7c665bf47f20d79a4bc9c4c7
parent93aca2270218edc9c1ae9e9b7a27b8c222a62efb (diff)
downloadaur-2c11446c.tar.gz
build using ffmpeg4.4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03cded3a48f1..0083990c3e75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electricsheep
pkgdesc = Screensaver that realize the collective dream of sleeping computers from all over the internet
pkgver = 3.0.2
- pkgrel = 3
+ pkgrel = 4
url = http://community.electricsheep.org/
arch = x86_64
license = GPL
@@ -11,7 +11,7 @@ pkgbase = electricsheep
makedepends = tinyxml
depends = curl
depends = flam3
- depends = ffmpeg
+ depends = ffmpeg4.4
depends = lua51
depends = libgtop
depends = boost-libs
@@ -24,4 +24,3 @@ pkgbase = electricsheep
sha256sums = 1b33414d05f1b611224192c6956bb1ef6d9f2cef530e3fd0b8b48aa812a58a0b
pkgname = electricsheep
-
diff --git a/PKGBUILD b/PKGBUILD
index 262ed48e7921..22f5310a44c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=electricsheep
pkgver=3.0.2
-pkgrel=3
+pkgrel=4
_gitcommit=1c4af20b384d19c6844083845004e8f467c9ce39
pkgdesc='Screensaver that realize the collective dream of sleeping computers from all over the internet'
url='http://community.electricsheep.org/'
arch=('x86_64')
license=('GPL')
-depends=('curl' 'flam3' 'ffmpeg' 'lua51' 'libgtop' 'boost-libs' 'freeglut' 'glee' 'wxgtk2')
+depends=('curl' 'flam3' 'ffmpeg4.4' 'lua51' 'libgtop' 'boost-libs' 'freeglut' 'glee' 'wxgtk2')
makedepends=('boost' 'mesa' 'glu' 'tinyxml')
optdepends=('xscreensaver: to use electricsheep with xscreensaver')
options=('!emptydirs')
@@ -29,6 +29,7 @@ prepare() {
build() {
cd ${pkgname}-${_gitcommit}/client_generic
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
CPPFLAGS+=" -I/usr/include/lua5.1" ./configure --prefix=/usr
sed -i 's|-I /usr/include/libavutil||' MSVC/SettingsGUI/Makefile
make CXXFLAGS+="-DUSE_NEW_FFMPEG_API=1 -DGL_GLEXT_PROTOTYPES" GLEE_LIBS="-lGLee" LDFLAGS+="-lpthread"