summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Pronko2022-05-01 12:39:14 +0300
committerPlaton Pronko2022-05-01 12:39:14 +0300
commit6bf9a1798babc4d8c2f90ac876fc28e4d6b85934 (patch)
tree8b2658508b55419f8d403bb368888b9a1c9024c4
parent5631f6736c9e6654a8b248bc8b54ac75c6f2193c (diff)
downloadaur-6bf9a1798babc4d8c2f90ac876fc28e4d6b85934.tar.gz
remove unused patches
-rw-r--r--electricsheep-ffmpeg30.patch89
-rw-r--r--electricsheep-no-wxgtk.patch77
2 files changed, 0 insertions, 166 deletions
diff --git a/electricsheep-ffmpeg30.patch b/electricsheep-ffmpeg30.patch
deleted file mode 100644
index 1206dea01ed8..000000000000
--- a/electricsheep-ffmpeg30.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff -rupN electricsheep-2.7b33.orig/Client/Player.cpp electricsheep-2.7b33/Client/Player.cpp
---- electricsheep-2.7b33.orig/Client/Player.cpp 2016-02-17 23:58:18.290031068 +0100
-+++ electricsheep-2.7b33/Client/Player.cpp 2016-02-18 00:00:10.793496143 +0100
-@@ -357,18 +357,18 @@ ContentDecoder::CContentDecoder *CPlayer
- return NULL;
-
- #ifndef LINUX_GNU
-- PixelFormat pf = PIX_FMT_RGB32;
-+ AVPixelFormat pf = AV_PIX_FMT_RGB32;
-
- //On PowerPC machines we need to use different pixel format!
- #if defined(MAC) && defined(__BIG_ENDIAN__)
-- pf = PIX_FMT_BGR32_1;
-+ pf = AV_PIX_FMT_BGR32_1;
- #endif
-
- #else
-
-- PixelFormat pf = PIX_FMT_BGR32;
-+ AVPixelFormat pf = AV_PIX_FMT_BGR32;
- #if defined(__BIG_ENDIAN__)
-- pf = PIX_FMT_RGB32_1;
-+ pf = AV_PIX_FMT_RGB32_1;
- #endif
-
- #endif
-diff -rupN electricsheep-2.7b33.orig/ContentDecoder/ContentDecoder.cpp electricsheep-2.7b33/ContentDecoder/ContentDecoder.cpp
---- electricsheep-2.7b33.orig/ContentDecoder/ContentDecoder.cpp 2016-02-17 23:58:18.293364307 +0100
-+++ electricsheep-2.7b33/ContentDecoder/ContentDecoder.cpp 2016-02-18 00:02:41.115898486 +0100
-@@ -42,7 +42,7 @@ namespace ContentDecoder
- CContentDecoder.
-
- */
--CContentDecoder::CContentDecoder( spCPlaylist _spPlaylist, bool _bStartByRandom, const uint32 _queueLenght, PixelFormat _wantedFormat )
-+CContentDecoder::CContentDecoder( spCPlaylist _spPlaylist, bool _bStartByRandom, const uint32 _queueLenght, AVPixelFormat _wantedFormat )
- {
- g_Log->Info( "CContentDecoder()" );
- m_FadeCount = g_Settings()->Get("settings.player.fadecount", 30);
-@@ -472,7 +472,7 @@ void CContentDecoder::ReadPackets()
- if( !NextSheepForPlaying() )
- return;
-
-- pFrame = avcodec_alloc_frame();
-+ pFrame = av_frame_alloc();
-
- while( true )
- {
-diff -rupN electricsheep-2.7b33.orig/ContentDecoder/ContentDecoder.h electricsheep-2.7b33/ContentDecoder/ContentDecoder.h
---- electricsheep-2.7b33.orig/ContentDecoder/ContentDecoder.h 2016-02-17 23:58:18.293364307 +0100
-+++ electricsheep-2.7b33/ContentDecoder/ContentDecoder.h 2016-02-18 00:00:43.602564223 +0100
-@@ -90,7 +90,7 @@ class CContentDecoder
- int32 m_VideoStreamID;
- AVFrame *m_pFrame;
-
-- PixelFormat m_WantedPixelFormat;
-+ AVPixelFormat m_WantedPixelFormat;
- SwsContext *m_pScaler;
-
- // These are to track changes in input stream resolution, and recreate m_pScaler if needed.
-@@ -126,7 +126,7 @@ class CContentDecoder
- static int DumpError( int _err );
-
- public:
-- CContentDecoder( spCPlaylist _spPlaylist, bool _bStartByRandom, const uint32 _queueLenght, PixelFormat _wantedPixelFormat = PIX_FMT_RGB24 );
-+ CContentDecoder( spCPlaylist _spPlaylist, bool _bStartByRandom, const uint32 _queueLenght, AVPixelFormat _wantedPixelFormat = AV_PIX_FMT_RGB24 );
- virtual ~CContentDecoder();
-
- bool Initialized() { return m_Initialized; }
-diff -rupN electricsheep-2.7b33.orig/ContentDecoder/Frame.h electricsheep-2.7b33/ContentDecoder/Frame.h
---- electricsheep-2.7b33.orig/ContentDecoder/Frame.h 2016-02-17 23:58:18.293364307 +0100
-+++ electricsheep-2.7b33/ContentDecoder/Frame.h 2016-02-18 00:02:17.963221084 +0100
-@@ -59,7 +59,7 @@ class CVideoFrame
- AVFrame *m_pFrame;
-
- public:
-- CVideoFrame( AVCodecContext *_pCodecContext, PixelFormat _format, std::string _filename ) : m_pFrame(NULL)
-+ CVideoFrame( AVCodecContext *_pCodecContext, AVPixelFormat _format, std::string _filename ) : m_pFrame(NULL)
- {
- assert( _pCodecContext );
- if ( _pCodecContext == NULL)
-@@ -75,7 +75,7 @@ class CVideoFrame
- m_Width = _pCodecContext->width;
- m_Height = _pCodecContext->height;
-
-- m_pFrame = avcodec_alloc_frame();
-+ m_pFrame = av_frame_alloc();
- if (m_pFrame != NULL)
- {
- int32 numBytes = avpicture_get_size( _format, _pCodecContext->width, _pCodecContext->height );
diff --git a/electricsheep-no-wxgtk.patch b/electricsheep-no-wxgtk.patch
deleted file mode 100644
index dd1a6026dc16..000000000000
--- a/electricsheep-no-wxgtk.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- configure.ac.orig 2014-08-17 17:28:46.314141026 -0400
-+++ configure.ac 2014-08-17 17:29:21.084084594 -0400
-@@ -71,64 +71,7 @@
-
-
-
--dnl Check for WXWidgets
--WX_VER_291=""
-
--AC_PATH_PROG(WX_CONFIG, wx-config, no)
--
--if test x$WX_CONFIG != xno; then
-- WX_VERSION=`wx-config --version`
--
-- WX_MAJOR=${WX_VERSION%%.*};
-- WX_MINOR=${WX_VERSION#*.};
-- WX_MINOR=${WX_MINOR%%.*};
-- WX_MICRO=${WX_VERSION##*.};
--
-- if test $WX_MAJOR -gt 2; then
-- WX_VER_291=yes
-- else
-- if test $WX_MAJOR -eq 2; then
-- if test $WX_MINOR -gt 9; then
-- WX_VER_291=yes
-- else
-- if test $WX_MINOR -eq 9; then
-- if test $WX_MICRO -ge 1; then
-- WX_VER_291=yes
-- fi
-- fi
-- fi
-- fi
-- fi
--fi
--
--if test "$WX_VER_291" != "yes"; then
--
--dnl Use static version
--echo "installed version is too old,"
--echo "using static source version $reqwx"
--
--dnl Need to reset this, else it will override the value below !
--WX_CONFIG=""
--
--AC_CHECK_PROG(WX_CONFIG, wx-config, yes, no)
--
--if test $WX_CONFIG = no; then
--echo
--echo YOU CAN FIX THIS !
--AC_MSG_ERROR([Please install development libraries for wxWidgets 2.9.1 or higher, and then run this configure script again.])
--fi
--fi
--
--WX_CXXFLAGS="`wx-config --cxxflags`"
--WX_LIBS="-static `wx-config --libs` `wx-config --libs richtext`"
--
--echo "WX_CXXFLAGS is $WX_CXXFLAGS"
--echo "WX_LIBS is $WX_LIBS"
--
--WX_LDADD="$WX_LIBS"
--
--AC_SUBST(WX_CXXFLAGS)
--AC_SUBST(WX_LDADD)
-
-
-
---- MSVC/SettingsGUI/Makefile.am.orig 2014-08-17 20:22:59.680508699 -0400
-+++ MSVC/SettingsGUI/Makefile.am 2014-08-17 20:23:46.397099541 -0400
-@@ -28,7 +28,6 @@
- -I /usr/include/libswscale \
- -I /usr/include/libavutil
-
--bin_PROGRAMS = electricsheep-preferences
-
- electricsheep_preferences_SOURCES = \
- config.cpp \