summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 15:05:58 +0800
committerzxp198210052024-03-22 15:05:58 +0800
commitc353904867aa766a377692d30ff1d76d8f3a2464 (patch)
tree8f245cf6b0c1f1078c71299b8ce4461591f54792
parent26cb11003e2d0959c1c2f655fd0f47c93fd37aab (diff)
downloadaur-electron-calculator-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--electron-calculator.sh5
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b849527a2b..218e58492533 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = electron-calculator-bin
pkgdesc = Simple electron calculator app
pkgver = 1.1.2
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Alex313031/electron-calculator
arch = x86_64
license = BSD-3-Clause
depends = electron22
- depends = hicolor-icon-theme
provides = electron-calculator
conflicts = electron-calculator
source = electron-calculator-1.1.2.deb::https://github.com/Alex313031/electron-calculator/releases/download/1.1.2/electron-calculator_1.1.2_amd64.deb
@@ -14,6 +13,6 @@ pkgbase = electron-calculator-bin
source = electron-calculator.sh
sha256sums = a24c56eb012c763c6c10ddf137ff4c72c0d8898776083baed52085bb78023664
sha256sums = 0971f64facd7071ec5e71edbac78a59937e0a82e1b1599ee45e5ce0e4735623e
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = electron-calculator-bin
diff --git a/PKGBUILD b/PKGBUILD
index 54f6f2207610..5204a355262f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=electron-calculator-bin
_pkgname="Electron Calculator"
pkgver=1.1.2
_electronversion=22
-pkgrel=4
+pkgrel=5
pkgdesc="Simple electron calculator app"
arch=('x86_64')
url="https://github.com/Alex313031/electron-calculator"
@@ -12,7 +12,6 @@ provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'hicolor-icon-theme'
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
@@ -21,11 +20,12 @@ source=(
)
sha256sums=('a24c56eb012c763c6c10ddf137ff4c72c0d8898776083baed52085bb78023664'
'0971f64facd7071ec5e71edbac78a59937e0a82e1b1599ee45e5ce0e4735623e'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/electron-calculator.sh b/electron-calculator.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/electron-calculator.sh
+++ b/electron-calculator.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file