summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-08-26 09:33:08 -0700
committerAndy Weidenbaum2017-08-26 09:33:08 -0700
commite6b98099b007d4b8abf90472b24d621761c5af1d (patch)
treed4919842c1e147cbf205f1775a68b29cc1ed1226
parentd8b94f0267415cc6b118e3d6a270b2d5d6addba4 (diff)
downloadaur-e6b98099b007d4b8abf90472b24d621761c5af1d.tar.gz
update pkgver to 20170826, switch to py3
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD58
2 files changed, 53 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23c3eb0323fa..e765f9883bef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 9 19:35:41 UTC 2017
+# Sat Aug 26 16:29:19 UTC 2017
pkgbase = electrum-git
pkgdesc = Lightweight Bitcoin wallet
- pkgver = 20170309
+ pkgver = 20170826
pkgrel = 1
url = https://github.com/spesmilo/electrum
install = electrum.install
@@ -11,31 +11,33 @@ pkgbase = electrum-git
makedepends = gettext
makedepends = git
makedepends = protobuf
- makedepends = python2-pycurl
- makedepends = python2-setuptools
+ makedepends = python-pycurl
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-requests
depends = hicolor-icon-theme
- depends = python2
- depends = python2-dnspython
- depends = python2-ecdsa
- depends = python2-jsonrpclib
- depends = python2-pbkdf2
- depends = python2-protobuf
- depends = python2-pyaes
- depends = python2-pyqt4
- depends = python2-pysocks
- depends = python2-qrcode
- depends = python2-requests
- depends = python2-six
+ depends = python
+ depends = python-dnspython
+ depends = python-ecdsa
+ depends = python-jsonrpclib-pelix
+ depends = python-pbkdf2
+ depends = python-protobuf
+ depends = python-pyaes
+ depends = python-pyqt4
+ depends = python-pysocks
+ depends = python-qrcode
+ depends = python-requests
+ depends = python-six
depends = qt4
optdepends = desktop-file-utils: update desktop icon
optdepends = gtk-update-icon-cache: update desktop icon
- optdepends = python2-amodem: air-gapped transaction signing over audio modem
- optdepends = python2-btchip: Ledger hardware wallet support
- optdepends = python2-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
- optdepends = python2-keepkey: KeepKey hardware wallet support
- optdepends = python2-matplotlib: plot transaction history in graphical mode
- optdepends = python2-rpyc: send commands to Electrum Python console from an external script
- optdepends = python2-trezor: Trezor hardware wallet support
+ optdepends = python-amodem: air-gapped transaction signing over audio modem
+ optdepends = python-btchip: Ledger hardware wallet support
+ optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
+ optdepends = python-keepkey: KeepKey hardware wallet support
+ optdepends = python-matplotlib: plot transaction history in graphical mode
+ optdepends = python-rpyc: send commands to Electrum Python console from an external script
+ optdepends = python-trezor: Trezor hardware wallet support
optdepends = xdg-utils: update desktop icon
optdepends = zbar: QR code reading support
provides = electrum
diff --git a/PKGBUILD b/PKGBUILD
index 0c11b9b6cce7..f6b8ae45d282 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,38 +8,40 @@
#
pkgname=electrum-git
-pkgver=20170309
+pkgver=20170826
pkgrel=1
pkgdesc="Lightweight Bitcoin wallet"
arch=('any')
depends=('hicolor-icon-theme'
- 'python2'
- 'python2-dnspython'
- 'python2-ecdsa'
- 'python2-jsonrpclib'
- 'python2-pbkdf2'
- 'python2-protobuf'
- 'python2-pyaes'
- 'python2-pyqt4'
- 'python2-pysocks'
- 'python2-qrcode'
- 'python2-requests'
- 'python2-six'
+ 'python'
+ 'python-dnspython'
+ 'python-ecdsa'
+ 'python-jsonrpclib-pelix'
+ 'python-pbkdf2'
+ 'python-protobuf'
+ 'python-pyaes'
+ 'python-pyqt4'
+ 'python-pysocks'
+ 'python-qrcode'
+ 'python-requests'
+ 'python-six'
'qt4')
makedepends=('gettext'
'git'
'protobuf'
- 'python2-pycurl'
- 'python2-setuptools')
+ 'python-pycurl'
+ 'python-setuptools'
+ 'python2'
+ 'python2-requests')
optdepends=('desktop-file-utils: update desktop icon'
'gtk-update-icon-cache: update desktop icon'
- 'python2-amodem: air-gapped transaction signing over audio modem'
- 'python2-btchip: Ledger hardware wallet support'
- 'python2-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
- 'python2-keepkey: KeepKey hardware wallet support'
- 'python2-matplotlib: plot transaction history in graphical mode'
- 'python2-rpyc: send commands to Electrum Python console from an external script'
- 'python2-trezor: Trezor hardware wallet support'
+ 'python-amodem: air-gapped transaction signing over audio modem'
+ 'python-btchip: Ledger hardware wallet support'
+ 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
+ 'python-keepkey: KeepKey hardware wallet support'
+ 'python-matplotlib: plot transaction history in graphical mode'
+ 'python-rpyc: send commands to Electrum Python console from an external script'
+ 'python-trezor: Trezor hardware wallet support'
'xdg-utils: update desktop icon'
'zbar: QR code reading support')
url="https://github.com/spesmilo/electrum"
@@ -59,25 +61,21 @@ build() {
cd ${pkgname%-git}
msg2 'Compiling icons...'
- pyrcc4 icons.qrc -o gui/qt/icons_rc.py
+ pyrcc4 icons.qrc -o gui/qt/icons_rc.py -py3
msg2 'Compiling protobuf description file...'
protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto
msg2 'Creating translations...'
- python2 contrib/make_locale
+ ./contrib/make_locale
msg2 'Building...'
- python2 setup.py build
+ python setup.py build
}
package() {
cd ${pkgname%-git}
msg2 'Installing...'
- python2 setup.py install --root="$pkgdir" --optimize=1
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+ python setup.py install --root="$pkgdir" --optimize=1
}