summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-05-06 17:28:43 +0800
committerzxp198210052024-05-06 17:28:43 +0800
commit0beab1717a01670577a047e3d4981516a8b58342 (patch)
tree82204e2b0a29cfec1ef8e75f21e586d498de2a38
parent09f63064550a6547a00302a19552e78713ec99b4 (diff)
downloadaur-elephicon.tar.gz
update to 3.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--elephicon.sh19
3 files changed, 30 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f404001929a..4c45a83a28a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = elephicon
pkgdesc = A GUI wrapper for png2icons, generates Apple ICNS and Microsoft ICO files from PNG files.
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/sprout2000/elephicon
arch = any
@@ -11,9 +11,9 @@ pkgbase = elephicon
makedepends = git
depends = electron30
conflicts = elephicon
- source = elephicon.git::git+https://github.com/sprout2000/elephicon.git#tag=v3.0.0
+ source = elephicon-3.0.1.tar.gz::https://github.com/sprout2000/elephicon/archive/refs/tags/v3.0.1.tar.gz
source = elephicon.sh
- sha256sums = c54c34394b6d4c19e9408759494a104e900b10cfaefff395c6c62c8db51173af
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = 9cad14e55de64187c299134885ea27dcf20835600834e36b6a5f57558978d51d
+ sha256sums = 05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a
pkgname = elephicon
diff --git a/PKGBUILD b/PKGBUILD
index 1fd50916ffbd..517dea4bfeb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=elephicon
-pkgver=3.0.0
+pkgver=3.0.1
_electronversion=30
_nodeversion=20
pkgrel=1
@@ -19,11 +19,11 @@ makedepends=(
'git'
)
source=(
- "${pkgname}.git::git+${url}.git#tag=v${pkgver}"
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
"${pkgname}.sh"
)
-sha256sums=('c54c34394b6d4c19e9408759494a104e900b10cfaefff395c6c62c8db51173af'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+sha256sums=('9cad14e55de64187c299134885ea27dcf20835600834e36b6a5f57558978d51d'
+ '05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
@@ -38,14 +38,14 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
_ensure_local_nvm
gendesk -q -f -n --categories="Graphics;Utility" --name="${pkgname}" --exec="${pkgname} %U"
- cd "${srcdir}/${pkgname}.git"
+ cd "${srcdir}/${pkgname}-${pkgver}"
export npm_config_build_from_source=true
export npm_config_cache="${srcdir}/.npm_cache"
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
export ELECTRONVERSION="${_electronversion}"
- export npm_config_disturl=https://electronjs.org/headers
+ export npm_config_disturl=https://registry.npmmirror.com/-/binary/node/
HOME="${srcdir}/.electron-gyp"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
export npm_config_registry=https://registry.npmmirror.com
@@ -61,10 +61,10 @@ build() {
}
package() {
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}.git/release/linux-"*/resources/app.asar -t "${pkgdir}/usr/lib/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}.git/release/linux-"*/resources/app.asar.unpacked/dist/images/icon.png \
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/release/linux-"*/resources/app.asar -t "${pkgdir}/usr/lib/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/release/linux-"*/resources/app.asar.unpacked/dist/images/icon.png \
-t "${pkgdir}/usr/lib/${pkgname}/app.asar.unpacked/dist/images"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "${srcdir}/${pkgname}.git/assets/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "${srcdir}/${pkgname}.git/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/assets/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/elephicon.sh b/elephicon.sh
index 7ddcaab8d734..5594e5380ba2 100644
--- a/elephicon.sh
+++ b/elephicon.sh
@@ -7,10 +7,23 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+declare -a flags
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ mapfile -t < "${_FLAGS_FILE}"
+fi
+for line in "${MAPFILE[@]}"; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]] && [[ -n "${line}" ]]; then
+ flags+=("${line}")
+ fi
+done
cd "${_APPDIR}"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file