summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2022-05-23 01:17:34 +0300
committerAnton Kudelin2022-05-23 01:17:34 +0300
commit52fa494312ca7ee791e60e6f622e02a9c0d0aa6c (patch)
treebde7d8073958cc4723d70220a2734fd2b139a8fc
parent3afd861ef59ce9a7d2a9927cec74026d66c5ac68 (diff)
downloadaur-52fa494312ca7ee791e60e6f622e02a9c0d0aa6c.tar.gz
applying a patch for qwt
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD24
-rw-r--r--qwt_6.2.patch35
3 files changed, 55 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee02e672ad76..3b646aad88ea 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = elmerfem
pkgdesc = A finite element software for multiphysical problems
pkgver = 9.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.elmerfem.org
arch = x86_64
license = GPL
makedepends = gcc-fortran
makedepends = cmake
+ makedepends = cli11
depends = arpack
depends = blas
depends = qt5-script
depends = netcdf-fortran
depends = mmg
- depends = qwt
depends = glu
+ depends = qwt
conflicts = elmerfem-git
options = !emptydirs
options = !makeflags
@@ -21,9 +22,11 @@ pkgbase = elmerfem
source = elmerfem.desktop
source = ElmerIce.patch
source = DCRComplexSolve.patch
+ source = qwt_6.2.patch
sha256sums = 08c5bf261e87ff37456c1aa0372db3c83efabe4473ea3ea0b8ec66f5944d1aa0
sha256sums = f4b39389e5f258c7860b8d7a6b171fb54bf849dc772f640ac5e7a12c7a384aca
sha256sums = 90287c988ac4f5beedf5221e81f624799ec3253c63a30695e1873044ac5a6515
sha256sums = fe117a9d803b7a12525d144fae936e1d3d7a3444c5b5a5697f95f772486a2db0
+ sha256sums = b6ed988029169a5af745187d6ffb3e73cb81f5287944aab273e4a1fdf50af91f
pkgname = elmerfem
diff --git a/PKGBUILD b/PKGBUILD
index 41c2d234d350..6c5aee8a8a4b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
-# Contributor: saxonbeta <saxonbeta [[at]] gmail _dot com
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: saxonbeta <saxonbeta [[at]] gmail _dot com
# Contributor: Randy Heydon <randy dot heydon at clockworklab dot net>
pkgname=elmerfem
pkgver=9.0
-pkgrel=2
+pkgrel=3
pkgdesc="A finite element software for multiphysical problems"
arch=('x86_64')
url="http://www.elmerfem.org"
license=('GPL')
-depends=('arpack' 'blas' 'qt5-script' 'netcdf-fortran' 'mmg' 'qwt' 'glu')
-makedepends=('gcc-fortran' 'cmake')
+depends=('arpack' 'blas' 'qt5-script' 'netcdf-fortran' 'mmg' 'glu' 'qwt')
+makedepends=('gcc-fortran' 'cmake' 'cli11')
conflicts=('elmerfem-git')
-options=(!emptydirs !makeflags)
source=("https://github.com/ElmerCSC/$pkgname/archive/release-$pkgver.tar.gz"
"$pkgname.desktop"
"ElmerIce.patch"
- "DCRComplexSolve.patch")
+ "DCRComplexSolve.patch"
+ "qwt_6.2.patch")
sha256sums=('08c5bf261e87ff37456c1aa0372db3c83efabe4473ea3ea0b8ec66f5944d1aa0'
'f4b39389e5f258c7860b8d7a6b171fb54bf849dc772f640ac5e7a12c7a384aca'
'90287c988ac4f5beedf5221e81f624799ec3253c63a30695e1873044ac5a6515'
- 'fe117a9d803b7a12525d144fae936e1d3d7a3444c5b5a5697f95f772486a2db0')
+ 'fe117a9d803b7a12525d144fae936e1d3d7a3444c5b5a5697f95f772486a2db0'
+ 'b6ed988029169a5af745187d6ffb3e73cb81f5287944aab273e4a1fdf50af91f')
+options=(!emptydirs !makeflags)
prepare() {
cd "$srcdir/$pkgname-release-$pkgver"
mkdir ../build
patch -p0 < "$srcdir/ElmerIce.patch"
patch -p0 < "$srcdir/DCRComplexSolve.patch"
+ patch -p1 < "$srcdir/qwt_6.2.patch"
sed -i '/#include <QPainter>/a #include <QPainterPath>' ElmerGUI/Application/twod/renderarea.cpp
}
@@ -34,6 +37,7 @@ build() {
cd "$srcdir/build"
cmake ../$pkgname-release-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="$CFLAGS -Wno-error=format-security" \
-DCMAKE_Fortran_FLAGS="$FCFLAGS -fallow-argument-mismatch -fallow-invalid-boz" \
-DMPI_Fortran_COMPILE_FLAGS="$FCFLAGS -fallow-argument-mismatch -fallow-invalid-boz" \
-DELMER_INSTALL_LIB_DIR=/usr/lib \
@@ -46,8 +50,10 @@ build() {
-DWITH_OpenMP=ON \
-DWITH_QT5=ON \
-DWITH_ScatteredDataInterpolator=ON \
- -DWITH_VTK=ON \
+ -DWITH_VTK=OFF \
-DWITH_MKL=OFF \
+ -DWITH_PYTHONQT=OFF \
+ -DWITH_QWT=ON \
-DOpenGL_GL_PREFERENCE=GLVND
make all
}
diff --git a/qwt_6.2.patch b/qwt_6.2.patch
new file mode 100644
index 000000000000..13eaf1c5f471
--- /dev/null
+++ b/qwt_6.2.patch
@@ -0,0 +1,35 @@
+From 48e9430ccb858ca5bda28b967a0c84b51e2404b2 Mon Sep 17 00:00:00 2001
+From: "E. Albiter" <ealbiter@gmail.com>
+Date: Fri, 15 Oct 2021 13:12:48 -0500
+Subject: [PATCH] Compatibility with Qwt 6.2. Fix for #293
+
+---
+ ElmerGUI/Application/src/convergenceview.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ElmerGUI/Application/src/convergenceview.h b/ElmerGUI/Application/src/convergenceview.h
+index 377b644b99..4259eb730e 100755
+--- a/ElmerGUI/Application/src/convergenceview.h
++++ b/ElmerGUI/Application/src/convergenceview.h
+@@ -51,8 +51,8 @@
+ #include <qwt_plot_curve.h>
+ #include <qwt_plot_grid.h>
+ #include <qwt_legend.h>
+-/*#include <qwt_data.h> <-- deprecated in Qwt6, using qwt_compat.h instead*/
+-#include <qwt_compat.h>
++/*#include <qwt_data.h> <-- deprecated in Qwt6, using qwt_compat.h instead
++#include <qwt_compat.h> <-- Removed in Qwt 6.2 */
+ #include <qwt_text.h>
+ #include <qwt_scale_engine.h>
+
+@@ -76,8 +76,8 @@ class CurveData
+
+ private:
+ int d_count;
+- QwtArray<double> d_x;
+- QwtArray<double> d_y;
++ QVector<double> d_x;
++ QVector<double> d_y;
+ };
+
+ class Curve