summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexchain Tong2016-02-15 23:42:11 +0800
committerHexchain Tong2016-02-15 23:42:11 +0800
commit0e66050e8c3fd775cab3ef7ad2f47356a12ffbb0 (patch)
tree336d50272cfad5ba0dd2c2676c548a1516f2bf8a
downloadaur-0e66050e8c3fd775cab3ef7ad2f47356a12ffbb0.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8f4b421edeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 15:41:40 UTC 2016
+pkgbase = elvish-git
+ pkgdesc = A novel Unix shell, aims to explore the potential of the Unix shell.
+ pkgver = r1397.5609dd1
+ pkgrel = 1
+ url = https://github.com/elves/elvish
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/elves/elvish.git
+ md5sums = SKIP
+
+pkgname = elvish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb68341c83f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Haochen Tong <i at hexchain dot org>
+
+pkgname=elvish-git
+_pkgname=elvish
+pkgver=r1397.5609dd1
+pkgrel=1
+pkgdesc="A novel Unix shell, aims to explore the potential of the Unix shell."
+arch=('i686' 'x86_64')
+url="https://github.com/elves/elvish"
+license=('MIT')
+makedepends=('git' 'go')
+source=("git+https://github.com/elves/elvish.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir"
+
+ mkdir -p build/src/github.com/elves
+ ln -sf "$srcdir/$_pkgname" build/src/github.com/elves/
+ export GOPATH="$srcdir/build"
+
+ go get github.com/elves/elvish
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ go build
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/elvish" -t "$pkgdir/usr/bin/"
+ install -Dm644 "$srcdir/$_pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+}