summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedlyk2015-06-23 23:26:34 +0200
committerknedlyk2015-06-23 23:26:34 +0200
commitb1ec06dc5fe8b705435924c83d44a42e369ccda2 (patch)
treec6ac389dc1b1f72390411782b2161569b876be14
downloadaur-em8300.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--2.6.35.patch15
-rw-r--r--PKGBUILD33
-rw-r--r--em8300.install24
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..394da56a6c1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = em8300
+ pkgdesc = DXR3 and Hollywood+ driver
+ pkgver = 0.18.0
+ pkgrel = 2
+ url = http://dxr3.sourceforge.net/
+ install = em8300.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = kernel26-headers>=2.6.33
+ depends = kernel26>=2.6.33
+ depends = em8300-utils=0.18.0
+ source = http://downloads.sourceforge.net/project/dxr3/em8300/0.18.0/em8300-0.18.0.tar.gz
+ source = 2.6.35.patch
+ md5sums = 2ef10f5159508a31a877e7e6d18c6896
+ md5sums = 922a6f5641a805ca05c2b712caeed9f8
+
+pkgname = em8300
+
diff --git a/2.6.35.patch b/2.6.35.patch
new file mode 100644
index 000000000000..1cc93daa495e
--- /dev/null
+++ b/2.6.35.patch
@@ -0,0 +1,15 @@
+*** ../include/linux/em8300.h.old 2010-08-04 00:33:05.352620013 +0300
+--- ../include/linux/em8300.h 2010-08-04 00:33:19.900620013 +0300
+***************
+*** 234,239 ****
+--- 234,243 ----
+ #include <linux/wait.h> /* wait_queue_head_t */
+ #include <linux/list.h> /* struct list_head */
+
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,34)
++ #include <linux/semaphore.h> /* struct semaphore */
++ #endif
++
+ #if defined(CONFIG_SND) || defined(CONFIG_SND_MODULE)
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,16)
+ #define snd_card_t struct snd_card
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ece234c989a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 12108 2010-02-27 14:47:28Z ibiru $
+# Contributor: Jaroslaw Swierczynski <swiergot@juvepoland.com>
+
+pkgname=em8300
+pkgver=0.18.0
+_kernver=2.6.35-ARCH
+pkgrel=2
+pkgdesc="DXR3 and Hollywood+ driver"
+arch=('i686' 'x86_64')
+url="http://dxr3.sourceforge.net/"
+license=('GPL2')
+depends=('kernel26>=2.6.33' "em8300-utils=$pkgver")
+makedepends=('kernel26-headers>=2.6.33')
+install=em8300.install
+source=(http://downloads.sourceforge.net/project/dxr3/em8300/${pkgver}/em8300-${pkgver}.tar.gz
+2.6.35.patch)
+md5sums=('2ef10f5159508a31a877e7e6d18c6896'
+ '922a6f5641a805ca05c2b712caeed9f8')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver/
+ patch -p1 < $srcdir/2.6.35.patch
+ cd $srcdir/$pkgname-$pkgver/modules
+ rm -f update_em8300_version.sh
+
+ sed -i "s!^KERNEL_LOCATION := .*\$!KERNEL_LOCATION := /lib/modules/${_kernver}/build!" Makefile
+
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+ chmod 644 $pkgdir/lib/modules/*/em8300/*.ko
+ sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/*.install
+}
diff --git a/em8300.install b/em8300.install
new file mode 100644
index 000000000000..0436e1dac1f5
--- /dev/null
+++ b/em8300.install
@@ -0,0 +1,24 @@
+# arg 1: the new package version
+post_install() {
+ echo
+ echo ">>> You may want to add one of the following lines to your /etc/modprobe.conf,"
+ echo ">>> depending on type of your card:"
+ echo ">>> install em8300 modprobe adv717x ; modprobe -i em8300 ; true"
+ echo ">>> install em8300 modprobe bt865 ; modprobe -i em8300 ; true"
+ echo
+ KERNEL_VERSION='2.6.35-ARCH'
+ depmod -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ KERNEL_VERSION='2.6.35-ARCH'
+ depmod -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the old package version
+post_remove() {
+ KERNEL_VERSION='2.6.35-ARCH'
+ depmod -v $KERNEL_VERSION > /dev/null 2>&1
+}