summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-06-06 11:29:17 -0400
committerAlex Whitt2017-06-06 11:29:17 -0400
commit4c181ba9c4fcb81385f2ea4d45a20e642126e8ab (patch)
treec435c5b3cdf2627aeff64424baa45a75316f89ba
downloadaur-emacs-buffer-move.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-buffer-move.install29
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..067f3a26d5ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Jun 6 15:28:29 UTC 2017
+pkgbase = emacs-buffer-move
+ pkgdesc = Swap buffers between windows in Emacs
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/lukhas/buffer-move
+ install = emacs-buffer-move.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-buffer-move-0.6.2.tar.gz::https://github.com/lukhas/buffer-move/archive/0.6.2.tar.gz
+ sha256sums = 570d9871752ee79f18bbfe1b12d920cebbb9b6139c9386e93d3734062071ef45
+
+pkgname = emacs-buffer-move
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdb865a783f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=buffer-move
+_pkgmaintainer=lukhas
+_pkgdestdirname=buffer-move
+_versionprefix=
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Swap buffers between windows in Emacs"
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('570d9871752ee79f18bbfe1b12d920cebbb9b6139c9386e93d3734062071ef45')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-buffer-move.install b/emacs-buffer-move.install
new file mode 100644
index 000000000000..213a850ef0b4
--- /dev/null
+++ b/emacs-buffer-move.install
@@ -0,0 +1,29 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'buffer-move)
+
+==> Bind the functions as you please:
+
+(global-set-key (kbd "<C-S-up>") 'buf-move-up)
+(global-set-key (kbd "<C-S-down>") 'buf-move-down)
+(global-set-key (kbd "<C-S-left>") 'buf-move-left)
+(global-set-key (kbd "<C-S-right>") 'buf-move-right)
+
+==> Or do the above with use-package:
+
+(use-package buffer-move
+ :bind ("C-S-<up>" . buf-move-up)
+ ("C-S-<down>" . buf-move-down)
+ ("C-S-<left>" . buf-move-left)
+ ("C-S-<right>" . buf-move-right))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}