summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-23 22:38:03 +0200
committerhaawda2018-04-23 22:38:03 +0200
commitcfd562f9169bc221dae8572cebc7855a4f59d478 (patch)
tree88f88e8c646845db7208db4732b10247a52212b2
parenta66ce7d9be8d7eb9833711ab89087d9d88e61642 (diff)
downloadaur-emacs-color-theme-solarized.tar.gz
add install file
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
-rw-r--r--solarized.install14
3 files changed, 34 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e99553fc956..4740b0c24301 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 23 20:37:35 UTC 2018
pkgbase = emacs-color-theme-solarized
pkgdesc = Solarized color theme for Emacs
pkgver = 1.0.0.beta2
- pkgrel = 1
+ pkgrel = 2
url = http://ethanschoonover.com/solarized
+ install = solarized.install
arch = any
license = MIT
- depends = emacs
+ makedepends = git
depends = emacs-color-theme
- source = http://ethanschoonover.com/solarized/files/solarized.zip
- sha256sums = 13e65141b4e46476acd94d97587a4770323ccf6f3b5ea5bf084c6c004f5e7866
+ source = git+https://github.com/sellout/emacs-color-theme-solarized#commit=f3ca8902ea056fb8e46cb09f09c96294e31cd4ee
+ md5sums = SKIP
pkgname = emacs-color-theme-solarized
diff --git a/PKGBUILD b/PKGBUILD
index 98d2a4ba1eba..583f6e8fd1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# See AUR interface for current maintainer.
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Victor van den Elzen <victor.vde@gmail.com>
pkgname=emacs-color-theme-solarized
pkgver=1.0.0.beta2
-pkgrel=1
+pkgrel=2
pkgdesc="Solarized color theme for Emacs"
-arch=(any)
+arch=('any')
url="http://ethanschoonover.com/solarized"
license=('MIT')
-depends=('emacs' 'emacs-color-theme')
-source=("http://ethanschoonover.com/solarized/files/solarized.zip")
-sha256sums=('13e65141b4e46476acd94d97587a4770323ccf6f3b5ea5bf084c6c004f5e7866')
+depends=('emacs-color-theme')
+makedepends=('git')
+source=("git+https://github.com/sellout/$pkgname#commit=f3ca8902ea056fb8e46cb09f09c96294e31cd4ee")
+md5sums=('SKIP')
+install=solarized.install
build() {
- cd "${srcdir}/solarized/emacs-colors-solarized"
- # sed -ie "s/:italic t//" color-theme-solarized.el # Disable italic comments
- emacs --batch --eval '(progn (push "." load-path) (byte-compile-file "color-theme-solarized.el"))'
+ cd $pkgname
+ emacs -Q -batch -L . -f batch-byte-compile *.el || true
}
package() {
- cd "${srcdir}/solarized/emacs-colors-solarized"
- mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/themes"
- cp color-theme-solarized.{el,elc} "${pkgdir}/usr/share/emacs/site-lisp/themes/"
- mkdir -p "${pkgdir}/usr/share/licenses/emacs-color-theme-solarized"
- cp LICENSE "${pkgdir}/usr/share/licenses/emacs-color-theme-solarized/"
+ cd $pkgname
+ install -Dm644 *{.el,.elc} -t "$pkgdir"/usr/share/emacs/site-lisp/
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/emacs-color-theme-solarized/
}
diff --git a/solarized.install b/solarized.install
new file mode 100644
index 000000000000..a66c04499a32
--- /dev/null
+++ b/solarized.install
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+post_install() {
+ cat << EOF
+==> To start using this package, add the following lines to your .emacs
+(require 'color-theme)
+(require 'color-theme-solarized)
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}