summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarms2019-01-13 23:17:32 +0100
committerHarms2019-01-13 23:17:32 +0100
commit7e9dd7a9b65224df61762f613f97aec4cf4d8549 (patch)
tree2a2b379115c229576226981954d6f26ccbd16b09
downloadaur-emacs-company-irony-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09ffbc511fd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-company-irony-git
+ pkgdesc = Provides a company-mode asynchronous completion backend for the C, C++ and Objective-C languages.
+ pkgver = 1.1.0.r0.g52aca45
+ pkgrel = 1
+ url = https://github.com/sarcasm/company-irony
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs-company-mode
+ depends = irony-mode
+ provides = emacs-company-irony
+ source = git+https://github.com/sarcasm/company-irony.git
+ sha256sums = SKIP
+
+pkgname = emacs-company-irony-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6abea51ac74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Harms <thotro at lyse dot net>
+_gituser="sarcasm"
+_gitrepo="company-irony"
+
+pkgname=emacs-company-irony-git
+pkgver=1.1.0.r0.g52aca45
+pkgrel=1
+pkgdesc="Provides a company-mode asynchronous completion backend for the C, C++ and Objective-C languages."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+provides=('emacs-company-irony')
+depends=('emacs-company-mode' 'irony-mode')
+makedepends=('git')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver()
+{
+ cd "${_gitrepo}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build()
+{
+ cd "${_gitrepo}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package()
+{
+ cd "${_gitrepo}"
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/"${_gitrepo}"/
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp/${_gitrepo}/
+}