summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2021-09-01 22:19:07 +0200
committergéballin2021-09-01 22:19:07 +0200
commit9155860c48804854ca2e400c5dd7a49575d06cb7 (patch)
tree269bd95dd38ae99858b376be39b08c2cfa83924a
downloadaur-emacs-ctags-update.tar.gz
Add the emacs ctags-update module to the aur.
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD20
-rw-r--r--emacs-ctags-update.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79ced75e3dd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-ctags-update
+ pkgdesc = Emacs functions for auto update of TAGS files using ctags
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/jixiuf/ctags-update
+ install = emacs-ctags-update.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = ctags
+ provides = emacs-ctags-update
+ source = emacs-ctags-update-1.1.tar.gz::https://github.com/jixiuf/ctags-update/archive/v1.1.tar.gz
+ sha256sums = 3a0f045da4e657c7d338f4bb419015822e115f279dfec8cc6204bf27e2f42048
+
+pkgname = emacs-ctags-update
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ebd96d7f005f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=emacs-ctags-update
+pkgver='1.1'
+pkgrel='1'
+pkgdesc="Emacs functions for auto update of TAGS files using ctags"
+url="https://github.com/jixiuf/ctags-update"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'ctags')
+makedepends=('git')
+provides=('emacs-ctags-update')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jixiuf/ctags-update/archive/v${pkgver}.tar.gz")
+sha256sums=('3a0f045da4e657c7d338f4bb419015822e115f279dfec8cc6204bf27e2f42048')
+install=${pkgname}.install
+
+package() {
+ cd ctags-update-${pkgver}
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/ctags-update
+ install -m644 *.el "${pkgdir}"/usr/share/emacs/site-lisp/ctags-update/
+} \ No newline at end of file
diff --git a/emacs-ctags-update.install b/emacs-ctags-update.install
new file mode 100644
index 000000000000..b2d65b324515
--- /dev/null
+++ b/emacs-ctags-update.install
@@ -0,0 +1,15 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'ctags-update)
+(ctags-global-auto-update-mode)
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}