summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-12 21:23:33 +0200
committersballert2018-09-12 21:23:33 +0200
commitb0f460c02f3f62d4de6f74057e60cbf3f4ff54bc (patch)
treec2513abe815f5804268442121606ad1c07044369
downloadaur-emacs-evil-nerd-commenter-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31c3751ac20a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-evil-nerd-commenter-git
+ pkgdesc = Comment/uncomment lines efficiently. Like Nerd Commenter in Vim
+ pkgver = r172.275c95c
+ pkgrel = 1
+ url = https://github.com/redguardtoo/evil-nerd-commenter
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-evil-nerd-commenter
+ conflicts = emacs-evil-nerd-commenter
+ source = git+https://github.com/redguardtoo/evil-nerd-commenter.git
+ sha256sums = SKIP
+
+pkgname = emacs-evil-nerd-commenter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e1ddfd41299
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="redguardtoo"
+_gitrepo="evil-nerd-commenter"
+
+pkgname=emacs-evil-nerd-commenter-git
+pkgver=r172.275c95c
+pkgrel=1
+pkgdesc="Comment/uncomment lines efficiently. Like Nerd Commenter in Vim"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-evil-nerd-commenter')
+conflicts=('emacs-evil-nerd-commenter')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}