summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-02-20 22:31:21 +0100
committerhaawda2020-02-20 22:31:21 +0100
commita26c15b2c470f3362f482ef329c18673929072de (patch)
tree2f8de96f8cbf5e2298bc04cf41c0ca522a60b5e1
parent99c2a332bb0157d07e6c552d627708742bfb66c3 (diff)
downloadaur-emacs-gnuplot-mode-git.tar.gz
package cosmetics
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b9c388a8be2..d5616dbd0245 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-gnuplot-mode-git
pkgdesc = Emacs-mode for writing gnuplot scripts
- pkgver = 0.7.0.29.g21f9046
- pkgrel = 2
+ pkgver = 0.7.0.34.ga406143
+ pkgrel = 1
url = https://github.com/bruceravel/gnuplot-mode
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index fca60781ec3c..8e46526c7002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=emacs-gnuplot-mode-git
-pkgver=0.7.0.29.g21f9046
-pkgrel=2
+pkgver=0.7.0.34.ga406143
+pkgrel=1
pkgdesc="Emacs-mode for writing gnuplot scripts"
arch=('any')
url="https://github.com/bruceravel/gnuplot-mode"
license=('GPL2')
makedepends=('git' 'emacs' 'texlive-bin') # latter only for gpelcard.pdf
-# should also work with xemacs or sxemacs
-source=("git+https://github.com/bruceravel/gnuplot-mode.git")
+source=("git+$url.git")
md5sums=('SKIP')
_gitname="gnuplot-mode"
pkgver() {
- cd "$srcdir"/"$_gitname"
+ cd $_gitname
git describe --tags | sed 's|-|.|g'
}
build() {
- cd "$srcdir"/"$_gitname"
+ cd $_gitname
autoreconf
./configure --with-lispdir=/usr/share/emacs/site-lisp \
EMACS=emacs # ... or xemacs or sxemacs
@@ -27,12 +27,12 @@ build() {
}
package() {
- cd "$srcdir/$_gitname"
+ cd $_gitname
make DESTDIR="$pkgdir/" install
for _i in .tex .pdf
do
install -Dm644 gpelcard${_i} \
- $pkgdir/usr/share/doc/emacs-gnuplot-mode/gpelcard${_i}
+ "$pkgdir"/usr/share/doc/emacs-gnuplot-mode/gpelcard${_i}
done
}