summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. A. López-Valencia2015-07-07 18:09:40 -0500
committerP. A. López-Valencia2015-07-07 18:09:40 -0500
commit9c6bab30890cf3489b963a9a5f0088787fe5e528 (patch)
treeec0d137fc443a6213464c39ecfeecc4974bdfc77
downloadaur-9c6bab30890cf3489b963a9a5f0088787fe5e528.tar.gz
2927-1
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD21
-rw-r--r--emacs-ipython-mode.install21
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20200a40ce20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = emacs-ipython-mode
+ pkgdesc = Emacs mode that replaces python-mode using the Ipython shell
+ pkgver = 2927
+ pkgrel = 1
+ url = http://ipython.scipy.org/moin/
+ install = emacs-ipython-mode.install
+ arch = any
+ license = GPL
+ depends = emacs
+ depends = ipython
+ depends = emacs-python-mode
+ depends = bash
+ source = http://archive.ipython.org/old-site/ipython.el
+ source = emacs-ipython-mode.install
+ sha256sums = 1ebd204c0a1796bb7a78be6007805f1c
+ sha256sums = 587258bb5e224af645e231ab17fe9a92
+
+pkgname = emacs-ipython-mode
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e78e7f3fd255
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+*~
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
+*.el
+*.elc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9277d742959a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# See AUR interface for current maintainer.
+# Contributor: L.G. Sarmiento <lgsarmientop-ala-unal.edu.co>
+# Contributor: Kostas Andreadis <kmandreadis@gmail.com>
+pkgname=emacs-ipython-mode
+pkgver=2927
+pkgrel=1
+pkgdesc="Emacs mode that replaces python-mode using the Ipython shell"
+arch=('any')
+url="http://ipython.scipy.org/moin/"
+license=('GPL')
+depends=('emacs' 'ipython' 'emacs-python-mode' 'bash')
+source=("http://archive.ipython.org/old-site/ipython.el"
+ 'emacs-ipython-mode.install')
+sha256sums=('1ebd204c0a1796bb7a78be6007805f1c'
+ '587258bb5e224af645e231ab17fe9a92')
+install=emacs-ipython-mode.install
+
+build() {
+ cd $startdir/src/
+ install -Dm644 $srcdir/ipython.el $pkgdir/usr/share/emacs/site-lisp/ipython.el
+}
diff --git a/emacs-ipython-mode.install b/emacs-ipython-mode.install
new file mode 100644
index 000000000000..2609352b7eab
--- /dev/null
+++ b/emacs-ipython-mode.install
@@ -0,0 +1,21 @@
+#!/bin/bash
+
+post_install() {
+
+ echo ""
+ echo "To enable auto-loading of ipython-mode, add these lines to your .emacs file:"
+ echo ""
+ echo "(autoload 'python-mode \"python-mode.el\" \"Python mode.\" t)"
+ echo "(setq auto-mode-alist (append '((\"/*.\.py$\" . python-mode)) auto-mode-alist))"
+ echo '(setq ipython-command "/usr/bin/ipython")'
+ echo '(setq py-python-command "/usr/bin/ipython")'
+ echo "(require 'ipython)"
+ echo ""
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+