summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-18 17:26:07 +0200
committersballert2018-09-18 17:26:07 +0200
commit0d801b49f09461dc03e9cf48d490254972e20f00 (patch)
tree1e84eea1bc1cc8c6416dd1c0e78c0421d6556f0e
downloadaur-emacs-ivy-pass-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80b6bd332aad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = emacs-ivy-pass-git
+ pkgdesc = ivy interface for pass
+ pkgver = r13.5b523de
+ pkgrel = 1
+ url = https://github.com/ecraven/ivy-pass
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-swiper
+ depends = emacs-password-store
+ provides = emacs-ivy-pass
+ conflicts = emacs-ivy-pass
+ source = git+https://github.com/ecraven/ivy-pass.git
+ sha256sums = SKIP
+
+pkgname = emacs-ivy-pass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c67a887f25d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="ecraven"
+_gitrepo="ivy-pass"
+
+pkgname=emacs-ivy-pass-git
+pkgver=r13.5b523de
+pkgrel=1
+pkgdesc="ivy interface for pass"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-swiper' 'emacs-password-store')
+makedepends=('git')
+provides=('emacs-ivy-pass')
+conflicts=('emacs-ivy-pass')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}