summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-04 13:05:28 -0400
committerAlex Whitt2017-05-04 13:05:28 -0400
commit8bc9d183569ab70db8fd9e0c8895d63d76eb0d09 (patch)
treeab8e0f176c0aaee73bd6bdd906a21778d9d30de5
parentab61e41488c50e13a6c0ae53ef0b608705bbaa93 (diff)
downloadaur-emacs-spaceline-all-the-icons.tar.gz
Adding sha256sums and install script
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD3
-rw-r--r--emacs-spaceline-all-the-icons.install20
3 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00c93d43630c..b7dbaf365411 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo v8
-# Wed May 3 22:10:43 UTC 2017
+# Thu May 4 17:04:54 UTC 2017
pkgbase = emacs-spaceline-all-the-icons
pkgdesc = A Spaceline Mode Line theme using All The Icons for Emacs
pkgver = 1.0.8
pkgrel = 1
url = https://github.com/domtronn/spaceline-all-the-icons.el
+ install = emacs-spaceline-all-the-icons.install
arch = any
license = MIT
depends = emacs
depends = emacs-spaceline
depends = emacs-all-the-icons
source = emacs-spaceline-all-the-icons-1.0.8.tar.gz::https://github.com/domtronn/spaceline-all-the-icons.el/archive/1.0.8.tar.gz
- sha256sums = SKIP
+ sha256sums = 9ce4dc7bdbf54134879245427de21ccc81f05e9263b81b82811dcaed5cd7ebee
pkgname = emacs-spaceline-all-the-icons
diff --git a/PKGBUILD b/PKGBUILD
index 3cceabc3167f..3f733f18f569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,8 @@ url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
license=('MIT')
depends=('emacs' 'emacs-spaceline' 'emacs-all-the-icons')
source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
-sha256sums=('SKIP')
+sha256sums=('9ce4dc7bdbf54134879245427de21ccc81f05e9263b81b82811dcaed5cd7ebee')
+install=${pkgname}.install
build() {
cd "${srcdir}/${_pkgsrcname}-${pkgver}"
diff --git a/emacs-spaceline-all-the-icons.install b/emacs-spaceline-all-the-icons.install
new file mode 100644
index 000000000000..f30c9fa0a757
--- /dev/null
+++ b/emacs-spaceline-all-the-icons.install
@@ -0,0 +1,20 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'spaceline-all-the-icons)
+
+==> Or, with use-package:
+
+(use-package spaceline-all-the-icons
+ :after spaceline
+ :config (spaceline-all-the-icons-theme))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}