summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-07-14 12:30:42 -0400
committerAlex Whitt2017-07-14 12:30:42 -0400
commit972b125c4c8537ffa4d64d61099d3d1c4302a055 (patch)
tree7f371258b1854334e2cf4f2bf1e43d83887b287e
downloadaur-emacs-twiki-mode.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--emacs-twiki-mode.install21
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b440da4d19b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jul 14 16:28:28 UTC 2017
+pkgbase = emacs-twiki-mode
+ pkgdesc = Major mode for editing Twiki wiki files for emacs, plus 'twikish' command line tool to retrieve and save twiki pages from text files.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/christopherjwhite/emacs-twiki-mode
+ install = emacs-twiki-mode.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = emacs-twiki-mode-1.3.1.tar.gz::https://github.com/christopherjwhite/emacs-twiki-mode/archive/1.3.1.tar.gz
+ sha256sums = 3339ba8e508a3e737bd54ace7265154efe25bd8b5e310e47db6ae63990623ab1
+
+pkgname = emacs-twiki-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c9c095176c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=emacs-twiki-mode
+_pkgmaintainer=christopherjwhite
+_pkgdestdirname=twiki-mode
+_versionprefix=
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Major mode for editing Twiki wiki files for emacs, plus 'twikish' command line tool to retrieve and save twiki pages from text files."
+pkgname=emacs-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('3339ba8e508a3e737bd54ace7265154efe25bd8b5e310e47db6ae63990623ab1')
+install=${pkgname}.install
+
+build() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+}
diff --git a/emacs-twiki-mode.install b/emacs-twiki-mode.install
new file mode 100644
index 000000000000..ff335f8ecedd
--- /dev/null
+++ b/emacs-twiki-mode.install
@@ -0,0 +1,21 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'twiki)
+(add-to-list 'auto-mode-alist'("\\.twiki$" . twiki-mode))
+
+==> Or, with use-package:
+
+(use-package twiki
+ :config
+ (add-to-list 'auto-mode-alist'("\\.twiki$" . twiki-mode)))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}