summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2019-09-01 12:32:29 -0500
committerPedro A. López-Valencia2019-09-01 12:32:29 -0500
commit4f2591bccb7858f461d992acf9e28c778e162ec6 (patch)
treefad28361f73058edefd5310fb01bad41a1646504
parent5c9dfb3de827a8f1bcf933b5b5ab71de4447e5f8 (diff)
downloadaur-4f2591bccb7858f461d992acf9e28c778e162ec6.tar.gz
27.0.50.138295
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD84
2 files changed, 39 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a10be4cf8d05..190ace88feb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development.
- pkgver = 27.0.50.138039
+ pkgver = 27.0.50.138295
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = emacs-git
depends = jansson
depends = libotf
depends = harfbuzz
+ depends = gpm
depends = gtk3
depends = libjpeg-turbo
depends = giflib
diff --git a/PKGBUILD b/PKGBUILD
index 6f3571ae1e84..4d0572d71961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,12 +20,14 @@
# =================================================
#
################################################################################
-CHECK= # Run tests. May fail, this is developement after all.
+CHECK="YES" # Run tests. May fail, this is developement after all.
CLANG= # Use clang.
-LTO= # Enable link-time optimization. Not that experimental anymore.
- # Broken with GCC, works (?) with clang, so clang is hardwired.
+LTO="YES" # Enable link-time optimization. Not that experimental anymore.
+ # Seems fixed in GCC, so I've reenabled binutils support, please
+ # report any bug, to make it use clang by default again.
CLI= # CLI only binary.
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
+LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
#
# Read https://wiki.archlinux.org/index.php/X_resources
# https://en.wikipedia.org/wiki/X_resources
@@ -33,9 +35,7 @@ NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
# for some tips on using outline fonts with
# Xft, if you choose no toolkit or Lucid.
#
-LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
GTK2= # GTK2 support. Why would you?
-GPM= # Enable gpm support.
M17N= # Enable m17n international table input support.
# You are far better off using harfbuzz+freetype2
# But this gives independence if you need it.
@@ -49,35 +49,39 @@ XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
DOCS_HTML= # Generate and install html documentation.
DOCS_PDF= # Generate and install pdf documentation.
MAGICK= # ImageMagick 7 support. Deprecated (read the logs).
- # ImageMagick, like flash, is bug ridden pest that won't die;
- # yet it is useful if you know what you are doing.
- # -->If you just *believe* you need it, you don't.<---
-NOGZ= # Don't compress .el files.
+ # ImageMagick, like flash, is a bug ridden pest that
+ # won't die; yet it is useful if you know what you
+ #are doing.
+ # -->>If you just *believe* you need it, you don't.<<--
+NOGZ="YES" # Don't compress .el files.
################################################################################
################################################################################
pkgname="emacs-git"
-pkgver=27.0.50.138039
+pkgver=27.0.50.138295
pkgrel=1
pkgdesc="GNU Emacs. Development."
arch=('x86_64') # Arch Linux only. Derivative users are on their own.
url="http://www.gnu.org/software/emacs/"
license=('GPL3')
-depends=( 'alsa-lib' 'gnutls' 'libxml2' 'jansson' 'libotf' 'harfbuzz' )
+depends=( 'alsa-lib' 'gnutls' 'libxml2' 'jansson' 'libotf' 'harfbuzz' 'gpm' )
makedepends=( 'git' )
+provides=('emacs' 'emacs-seq')
+conflicts=('emacs' 'emacs-seq')
+replaces=('emacs26-git' 'emacs-seq')
+source=("emacs-git::git+https://github.com/emacs-mirror/emacs.git")
+# If Github access is blocked for reasons, use Savannah's servers instead.
+# Edit the config file of your local repo copy as well.
+#source=("emacs-git::git://git.sv.gnu.org/emacs.git")
+#source=("emacs-git::git+https://git.savannah.gnu.org/emacs.git")
+md5sums=('SKIP')
################################################################################
################################################################################
-#
-# FYI, LTO fails with gcc.
-#
if [[ $LTO = "YES" ]]; then
- CLANG="YES" ;
-fi
-
-if [[ $CLI = "YES" ]]; then
- GPM="YES" ;
+ CFLAGS+=" -flto=jobserver -fuse-linker-plugin"
+ CXXFLAGS+=" -flto=jobserver -fuse-linker-plugin"
fi
if [[ $CLANG = "YES" ]]; then
@@ -100,10 +104,6 @@ else
depends+=( 'gtk3' );
fi
-if [[ $GPM = "YES" ]]; then
- depends+=( 'gpm');
-fi
-
if [[ $M17N = "YES" ]]; then
depends+=( 'm17n-lib' );
fi
@@ -139,24 +139,14 @@ fi
################################################################################
################################################################################
-provides=('emacs' 'emacs-seq')
-conflicts=('emacs' 'emacs-seq')
-replaces=('emacs26-git' 'emacs-seq')
-source=("emacs-git::git+https://github.com/emacs-mirror/emacs.git")
-# If Github access is blocked for reasons, use Savannah's servers instead.
-# Edit the config file of your local repo copy as well.
-#source=("emacs-git::git://git.sv.gnu.org/emacs.git")
-#source=("emacs-git::git+https://git.savannah.gnu.org/emacs.git")
-md5sums=('SKIP')
-
- pkgver() {
- cd "$srcdir/emacs-git"
+pkgver() {
+ cd "$srcdir/emacs-git"
- printf "%s.%s" \
- "$(grep AC_INIT configure.ac | \
- sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\?\).\+$/\1/')" \
- "$(git rev-list --count HEAD)"
- }
+ printf "%s.%s" \
+ "$(grep AC_INIT configure.ac | \
+ sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\?\).\+$/\1/')" \
+ "$(git rev-list --count HEAD)"
+}
# There is no need to run autogen.sh after first checkout.
# Doing so, breaks incremental compilation.
@@ -165,6 +155,13 @@ prepare() {
[[ -x configure ]] || ( ./autogen.sh git && ./autogen.sh autoconf )
}
+if [[ $CHECK = "YES" ]]; then
+check() {
+ cd "$srcdir/emacs-git"
+ make check
+}
+fi
+
build() {
cd "$srcdir/emacs-git"
@@ -213,10 +210,6 @@ else
_conf+=( '--with-x-toolkit=gtk3' '--without-xaw3d' );
fi
-if [[ ! $GPM = "YES" ]]; then
- _conf+=( '--without-gpm' );
-fi
-
if [[ ! $M17N = "YES" ]]; then
_conf+=( '--without-m17n-flt' );
fi
@@ -274,9 +267,6 @@ fi
if [[ $DOCS_PDF = "YES" ]]; then
make pdf;
fi
- if [[ $CHECK = "YES" ]]; then
- make check;
- fi
}