summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2017-06-30 14:16:49 -0500
committerPedro A. López-Valencia2017-06-30 14:16:49 -0500
commit6059ca84f0d4952a94784da3af7b6acb7ee00682 (patch)
tree20a527a9b601af0b869a413682f357c2c4d21c42
parentb841d66381303060cf1c1c0fa66e1c6d3877d98e (diff)
downloadaur-6059ca84f0d4952a94784da3af7b6acb7ee00682.tar.gz
emacs-git 26.0.50.129666-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD146
2 files changed, 96 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4289d7024c4..ad037910c91a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Master development branch.
- pkgver = 26.0.50.129323
+ pkgver = 26.0.50.129666
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = git
depends = alsa-lib
depends = gtk3
+ depends = libotf
+ depends = imagemagick
depends = libxpm
depends = libjpeg-turbo
depends = libtiff
depends = giflib
depends = libpng
depends = librsvg
+ depends = webkit2gtk
provides = emacs
conflicts = emacs
source = emacs-git::git+https://github.com/emacs-mirror/emacs.git
diff --git a/PKGBUILD b/PKGBUILD
index a1da11b420f7..075e0efab390 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,10 @@
#######################################################################
# CAVEAT LECTOR: This PKGBUILD is highly opinionated. I give you
-# rope to hang yourself, but by default it only
-# enables the features I use.
-#######################################################################
-
-#######################################################################
+# enough rope to hang yourself, but by default it
+# only enables the features I use.
#
-# Keeping this directory in a safe place preserves the
-# git repo and the src dir for faster compilation if
-# you want. You may delete the pkg dir after successfully
-# creating a package.
+# TL;DR: yaourt users, cry me a river.
#
#######################################################################
@@ -23,62 +17,81 @@
# =================================================
#
#######################################################################
-LTO= # Enable link-time optimization. Experimental.
-ATHENA= # Use Athena widgets. (83 1337, 83 001d sk00l).
-GTK2= # Leave empty to compile with gtk+ 3 support.
- # No, gtk+ 2 ain't kool, dawg!
-NOGTK3= # Leave empty to compile with gtk+ 3 support.
-GPM= # Enable gpm support.
-M17N= # Enable m17n international support.
-IMAGIGK= # ImageMagick is worse than Adobe Flash.
-CAIRO= # Highly experimental.
-XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
-DOCS_HTML= # Generate and install html documentation.
-DOCS_PDF= # Generate and install pdf documentation.
+CLANG= # Use clang.
+LTO= # Enable link-time optimization. Experimental.
+ATHENA= # Use Athena widgets. (83 1337, 83 001d sk00l).
+GTK2= # Leave empty to compile with gtk+ 3 support.
+ # No, gtk+ 2 ain't kool, dawg!
+NOGTK3= # Leave empty to compile with gtk+ 3 support.
+GPM= # Enable gpm support.
+M17N= # Enable m17n international support.
+OTF="YES" # OTF font support. Also a secondary dependency
+ # by pulling m17n-lib. Not needed in that case.
+CAIRO= # Highly experimental.
+XWIDGETS="YES" # Use GTK+ widgets pulled from webkit2gtk. Usable.
+DOCS_HTML= # Generate and install html documentation.
+DOCS_PDF= # Generate and install pdf documentation.
+MAGICK="YES" # Imagemagick is like flash; and still needed :-(
+NOGZ="YES" # Don't compress el files. Info and man pages are
+ # compressed by hooks anyway.
#######################################################################
#######################################################################
pkgname=emacs-git
-pkgver=26.0.50.129323
+pkgver=26.0.50.129666
pkgrel=1
pkgdesc="GNU Emacs. Master development branch."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/"
-license=('GPL')
-depends=('alsa-lib')
-makedepends=('git')
+license=('GPL3')
+depends=( 'alsa-lib' )
+makedepends=( 'git' )
#######################################################################
#######################################################################
+if [[ $CLANG = "YES" ]]; then
+ export CC=/usr/bin/clang ;
+ export CXX=/usr/bin/clang++ ;
+ makedepends+=( 'clang') ;
+fi
+
if [[ $ATHENA = "YES" ]]; then
- depends+=('libxaw');
+ depends+=( 'libxaw' );
fi
if [[ $GTK2 = "YES" ]]; then
- depends+=('gtk2');
+ depends+=( 'gtk2' );
else
if [[ ! $NOGTK3 = "YES" ]]; then
- depends+=('gtk3');
+ depends+=( 'gtk3' );
fi
fi
if [[ $GPM = "YES" ]]; then
- depends+=('gpm');
+ depends+=( 'gpm');
fi
if [[ $M17N = "YES" ]]; then
- depends+=('m17n-lib');
+ depends+=( 'm17n-lib' );
+fi
+
+if [[ $OTF = "YES" ]] && [[ ! $M17N = "YES" ]]; then
+ depends+=( 'libotf' );
fi
-if [[ $IMAGICK = "YES" ]]; then
- depends+=('imagemagick');
-else
- depends+=('libxpm' 'libjpeg-turbo' 'libtiff' \
- 'giflib' 'libpng' 'librsvg');
+if [[ $MAGICK = "YES" ]]; then
+ depends+=( 'imagemagick' );
+ depends+=( 'libxpm' 'libjpeg-turbo' 'libtiff' );
+ depends+=( 'giflib' 'libpng' 'librsvg' );
+elif [[ ! $NOX = "YES" ]]; then
+ depends+=( 'libxpm' 'libjpeg-turbo' 'libtiff' );
+ depends+=( 'giflib' 'libpng' 'librsvg' );
+else
+ depends+=();
fi
if [[ $CAIRO = "YES" ]]; then
- depends+=('cairo');
+ depends+=( 'cairo' );
fi
if [[ $XWIDGETS = "YES" ]]; then
@@ -90,12 +103,12 @@ if [[ $XWIDGETS = "YES" ]]; then
echo "";
exit 1;
else
- depends+=('webkit2gtk');
+ depends+=( 'webkit2gtk' );
fi
fi
if [[ $DOCS_PDF = "YES" ]]; then
- makedepends+=('texlive-core');
+ makedepends+=( 'texlive-core' );
fi
#######################################################################
@@ -145,41 +158,57 @@ build() {
#######################################################################
#######################################################################
+if [[ $CLANG = "YES" ]]; then
+ _conf+=(
+ '--enable-autodepend'
+ );
+fi
if [[ $LTO = "YES" ]]; then
- _conf+=('--enable-link-time-optimization');
+ _conf+=(
+ '--enable-link-time-optimization'
+ );
fi
if [[ $ATHENA = "YES" ]]; then
- _conf+=('--with-x-toolkit=athena' '--without-gconf' '--without-gsettings');
+ _conf+=(
+ '--with-x-toolkit=athena'
+ '--without-gconf'
+ '--without-gsettings'
+ );
fi
if [[ $GTK2 = "YES" ]]; then
- _conf+=('--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings');
+ _conf+=( '--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings' );
else
- _conf+=('--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings');
+ _conf+=( '--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings' );
fi
if [[ ! $GPM = "YES" ]]; then
- _conf+=('--without-gpm');
+ _conf+=( '--without-gpm' );
fi
if [[ ! $M17N = "YES" ]]; then
- _conf+=('--without-m17n-flt');
+ _conf+=( '--without-m17n-flt' );
fi
-if [[ $IMAGICK = "YES" ]]; then
- _conf+=('--without-xpm' '--without-jpeg' '--without-tiff'
- '--without-gif' '--without-png' '--without-rsvg');
-else
- _conf+=('--without-imagemagick');
-fi
+#if [[ $IMAGICK = "YES" ]]; then
+# _conf+=(
+# '--with-imagemagick'
+# );
+#else
+# _conf+=( '--without-imagemagick' );
+#fi
if [[ $CAIRO = "YES" ]]; then
- _conf+=('--with-cairo');
+ _conf+=( '--with-cairo' );
fi
if [[ $XWIDGETS = "YES" ]]; then
- _conf+=('--with-xwidgets');
+ _conf+=( '--with-xwidgets' );
+fi
+
+if [[ $NOGZ = "YES" ]]; then
+ _conf+=( '--without-compress-install' );
fi
#######################################################################
@@ -222,7 +251,12 @@ package() {
# remove conflict with ctags package
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
+
+ if [[ $NOGZ = "YES" ]]; then
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1,ctags.emacs.1};
+ else
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
+ fi
# fix user/root permissions on usr/share files
find "$pkgdir"/usr/share/emacs/ | xargs chown root:root
@@ -236,8 +270,10 @@ package() {
# The logic used to install systemd's user service is partially broken
# under Arch Linux model, because it adds $DESTDIR as prefix to the
# final Exec targets. The fix is to hack it with an axe.
- install -Dm644 etc/emacs.service "$pkgdir"/usr/lib/systemd/user/emacs.service
- sed -i -e 's#\(ExecStart\=\)#\1\/usr\/bin\/#' -e 's#\(ExecStop\=\)#\1\/usr\/bin\/#' \
+ install -Dm644 etc/emacs.service \
+ "$pkgdir"/usr/lib/systemd/user/emacs.service
+ sed -i -e 's#\(ExecStart\=\)#\1\/usr\/bin\/#' \
+ -e 's#\(ExecStop\=\)#\1\/usr\/bin\/#' \
"$pkgdir"/usr/lib/systemd/user/emacs.service
}