summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.A. López-Valencia2016-04-29 14:11:22 -0500
committerP.A. López-Valencia2016-04-29 14:11:22 -0500
commitb1c1af0a9185b90dcaaf977356776afc8d21ff37 (patch)
tree0f74fa248073e2f0ac66c4c810e61a9900edf5e7
parentb56e970a9264b606bc6ce63ae3ed7ed4352eb275 (diff)
downloadaur-b1c1af0a9185b90dcaaf977356776afc8d21ff37.tar.gz
Typo fix. Now it uses GTK+2 for real.
Argh!!! Options were broken and it was using GTK3 instead of GTK2! I mistyped the toolkit selection config flag. I have the memory retention of a gnat...
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff7a362e1c3d..9c312d378a9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-git
- pkgdesc = GNU Emacs. Version 25 development and maintenance branch.
- pkgver = 25.1.50.r125751
- pkgrel = 2
+ pkgdesc = GNU Emacs. Master development branch.
+ pkgver = 25.1.50.r125786
+ pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 166921744213..4e82ee916e23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
+# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
#######################################################################
# CAVEAT LECTOR
@@ -22,20 +22,20 @@
# calculated at all. Emacs opens in a very small frame.
# From within emacs, search for the options initial-frame-alist
# and default-frame-alist to set up emacs frame geometry to
-# your personal preference.
+# your personal preference. Switching to GTK+2 fixes it for now.
#
#######################################################################
#######################################################################
#
-# Still reading? Here kid, have enough rope to hang yourself.
+# Still reading? Here kid, have enough rope to hang yourself. :-)
#
#######################################################################
#######################################################################
# Assign "YES" to the variable you want enabled, empty otherwise
#######################################################################
-GTK3= # Leave empty to compile with gtk+ 2 support
+GTK3= # Leave empty to compile with gtk+ 2 support. BTW, gtk3 is broken.
LTO= # Enable link-time optimization. Broken.
CAIRO= # Very broken for me. Use at own risk.
XWIDGETS= # Use GTK+ native widgets pulled from webkitgtk.
@@ -44,9 +44,9 @@ DOCS_PDF= # Generate and install pdf documentation.
#######################################################################
pkgname=emacs-git
-pkgver=25.1.50.r125751
-pkgrel=2
-pkgdesc="GNU Emacs. Version 25 development and maintenance branch."
+pkgver=25.1.50.r125786
+pkgrel=1
+pkgdesc="GNU Emacs. Master development branch."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/"
license=('GPL')
@@ -56,7 +56,7 @@ makedepends=('git')
#######################################################################
if [[ $GTK3 = "YES" ]]; then depends+=('gtk3'); else depends+=('gtk2'); fi
if [[ $CAIRO = "YES" ]]; then depends+=('cairo'); fi
-if [[ $XWIDGETS = "YES" ]]; then
+if [[ $XWIDGETS = "YES" ]]; then
if [[ $GTK3 = "YES" ]]; then depends+=('webkitgtk'); else depends+=('webkitgtk2'); fi
fi
if [[ $DOCS_PDF = "YES" ]]; then makedepends+=('texlive-core'); fi
@@ -66,6 +66,7 @@ conflicts=('emacs')
provides=('emacs')
source=("$pkgname::git://git.savannah.gnu.org/emacs.git")
md5sums=('SKIP')
+#source=("$pkgname::git+http://git.savannah.gnu.org/r/emacs.git#branch")
pkgver() {
cd "$srcdir/$pkgname"
@@ -101,9 +102,9 @@ build() {
#######################################################################
#######################################################################
if [[ $GTK3 = "YES" ]]; then
- _conf+=('--with-xtoolkit=gtk3' '--without-gconf' '--without-gsettings');
+ _conf+=('--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings');
else
- _conf+=('--with-xtoolkit=gtk2' '--without-gconf' '--without-gsettings');
+ _conf+=('--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings');
fi
if [[ $LTO = "YES" ]]; then _conf+=('--enable-link-time-optimization'); fi
if [[ $CAIRO = "YES" ]]; then _conf+=('--with-cairo'); fi