summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.A. López-Valencia2016-10-29 09:39:12 -0500
committerP.A. López-Valencia2016-10-29 09:39:12 -0500
commitf4a2572803c00585a6a5a39493210a9ac7b15263 (patch)
tree78f2616adc26bb1340305a8ea460db9547810e1e
parentfbc07433aa7a884bafbcfd412f25ab734a39016e (diff)
downloadaur-f4a2572803c00585a6a5a39493210a9ac7b15263.tar.gz
emacs-git-26.0.50.127317-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD38
2 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65d2cec4b9dc..6fd226c9b024 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Master development branch.
- pkgver = 26.0.50.127315
+ pkgver = 26.0.50.127317
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = i686
@@ -12,7 +12,7 @@ pkgbase = emacs-git
depends = alsa-lib
depends = imagemagick
depends = gtk3
- depends = webkit2gtk
+ depends = giflib
provides = emacs
conflicts = emacs
source = emacs-git::git://git.savannah.gnu.org/emacs.git
diff --git a/PKGBUILD b/PKGBUILD
index 16d341c1a9c2..8682321b79fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,18 +28,21 @@
#######################################################################
# Assign "YES" to the variable you want enabled, empty otherwise
+#
+# Where you read experimental, replace with foobar.
+# =============================================================
+#
#######################################################################
-GTK3="YES" # Leave empty to compile with gtk+ 2 support.
-LTO= # Enable link-time optimization. Broken.
-CAIRO= # Very broken for everyone. Use at own risk.
-XWIDGETS= # Use GTK+ native widgets pulled from webkitgtk.
- # Experimental as in: It will break and eat your homework.
+GTK2= # Leave empty to compile with gtk+ 3 support.
+LTO= # Enable link-time optimization. Experimental.
+CAIRO= # Highly experimental.
+XWIDGETS= # Use GTK+ widgets pulled from webkitgtk. Experimental.
DOCS_HTML= # Generate and install html documentation.
DOCS_PDF= # Generate and install pdf documentation.
#######################################################################
pkgname=emacs-git
-pkgver=26.0.50.127315
+pkgver=26.0.50.127317
pkgrel=1
pkgdesc="GNU Emacs. Master development branch."
arch=('i686' 'x86_64')
@@ -49,18 +52,23 @@ depends=('gpm' 'm17n-lib' 'alsa-lib' 'imagemagick')
makedepends=('git')
#######################################################################
#######################################################################
-if [[ $GTK3 = "YES" ]]; then
- depends+=('gtk3');
+if [[ $GTK2 = "YES" ]]; then
+ depends+=('gtk2');
else
- depends+=('gtk2');
+ depends+=('gtk3');
fi
if [[ $CAIRO = "YES" ]]; then depends+=('cairo'); fi
if [[ $XWIDGETS = "" ]]; then depends+=('giflib'); fi
if [[ $XWIDGETS = "YES" ]]; then
- if [[ $GTK3 = "YES" ]]; then
- depends+=('webkit2gtk');
+ if [[ $GTK2 = "YES" ]]; then
+ echo "";
+ echo "";
+ echo "Xwidgets support *requires* gtk+3!!!";
+ echo "";
+ echo "";
+ exit 1;
else
- depends+=('webkitgtk2');
+ depends+=('webkit2gtk');
fi
fi
if [[ $DOCS_PDF = "YES" ]]; then makedepends+=('texlive-core'); fi
@@ -108,10 +116,10 @@ build() {
#######################################################################
#######################################################################
- if [[ $GTK3 = "YES" ]]; then
- _conf+=('--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings');
- else
+ if [[ $GTK2 = "YES" ]]; then
_conf+=('--with-x-toolkit=gtk2' '--with-gconf' '--without-gsettings');
+ else
+ _conf+=('--with-x-toolkit=gtk3' '--without-gconf' '--with-gsettings');
fi
if [[ $LTO = "YES" ]]; then _conf+=('--enable-link-time-optimization'); fi
if [[ $CAIRO = "YES" ]]; then _conf+=('--with-cairo'); fi