summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-03-19 17:42:00 -0500
committerPedro A. López-Valencia2021-03-19 17:42:00 -0500
commit8bcd071211e0df8ffeff4436ae66b73ecfdca5e0 (patch)
tree3c9062f9a1e44628f8619145a87da8c5b24e9387
parent393b02472dc55e55fc662ab7c518965cea3867b8 (diff)
downloadaur-8bcd071211e0df8ffeff4436ae66b73ecfdca5e0.tar.gz
28.0.50.145974-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 35 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5627d0c308b3..f1ccfe809931 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.144634
- pkgrel = 2
+ pkgver = 28.0.50.145975
+ pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
license = GPL3
@@ -11,26 +11,32 @@ pkgbase = emacs-git
depends = gnutls
depends = libxml2
depends = jansson
+ depends = gpm
depends = m17n-lib
depends = libotf
depends = harfbuzz
- depends = gpm
depends = gtk3
depends = libjpeg-turbo
depends = giflib
depends = cairo
provides = emacs
+ provides = emacs26-git
+ provides = emacs-27-git
provides = emacs-seq
+ provides = emacs-nox
conflicts = emacs
conflicts = emacs26-git
conflicts = emacs-27-git
conflicts = emacs-seq
+ conflicts = emacs-nox
+ replaces = emacs
replaces = emacs26-git
- replaces = emacs27-git
+ replaces = emacs-27-git
replaces = emacs-seq
+ replaces = emacs-nox
options = !strip
source = emacs-git::git://git.savannah.gnu.org/emacs.git
- md5sums = SKIP
+ b2sums = SKIP
pkgname = emacs-git
diff --git a/PKGBUILD b/PKGBUILD
index 9ea97ca51533..aa493b4fe5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,24 +47,28 @@ NOGZ="YES" # Don't compress .el files.
################################################################################
################################################################################
+if [[ $CLI == "YES" ]] ; then
+ pkgname="emacs-nox-git"
+else
pkgname="emacs-git"
-pkgver=28.0.50.144634
-pkgrel=2
+fi
+pkgver=28.0.50.145975
+pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
-arch=('x86_64' )
+arch=('x86_64')
url="http://www.gnu.org/software/emacs/"
-license=('GPL3' )
-depends=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'm17n-lib' 'libotf' 'harfbuzz' 'gpm')
+license=('GPL3')
+depends_nox=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'gpm')
+depends=("${depends_nox[@]}" 'm17n-lib' 'libotf' 'harfbuzz')
makedepends=('git')
-provides=('emacs' 'emacs-seq')
-conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq')
-replaces=('emacs26-git' 'emacs27-git' 'emacs-seq')
+provides=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
+conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
+replaces=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq' 'emacs-nox')
source=("emacs-git::git://git.savannah.gnu.org/emacs.git")
-# If Savannah access is blocked for reasons, use Github instead.
-# Edit the config file of your local repo copy as well.
+# I've given up on Savannah for the time being. A shame...
#source=("emacs-git::git://github.com/emacs-mirror/emacs.git")
options=(!strip)
-md5sums=('SKIP')
+b2sums=('SKIP')
################################################################################
################################################################################
@@ -102,7 +106,9 @@ else
fi
fi
-if [[ $NOTKIT == "YES" ]]; then
+if [[ $CLI == "YES" ]]; then
+ depends=("${depends_nox[@]}");
+elif [[ $NOTKIT == "YES" ]]; then
depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' );
makedepends+=( 'xorgproto' );
elif [[ $LUCID == "YES" ]]; then
@@ -124,7 +130,7 @@ else
depends+=();
fi
-if [[ ! $NOCAIRO == "YES" ]]; then
+if [[ ! $NOCAIRO == "YES" ]] && [[ ! $CLI == "YES" ]] ; then
depends+=( 'cairo' );
fi
@@ -224,7 +230,7 @@ else
_conf+=();
fi
-if [[ $NOCAIRO == "YES" ]]; then
+if [[ $NOCAIRO == "YES" || $CLI == "YES" ]]; then
_conf+=( '--without-cairo' );
fi
@@ -235,6 +241,10 @@ fi
if [[ $NOGZ == "YES" ]]; then
_conf+=( '--without-compress-install' );
fi
+
+# ctags/etags may be provided by other packages, e.g, universal-ctags
+conf+=('--program-transform-name="s/\([ec]tags\)/\1.emacs/"')
+
################################################################################
################################################################################
@@ -275,15 +285,6 @@ package() {
if [[ $DOCS_HTML == "YES" ]]; then make DESTDIR="$pkgdir/" install-html; fi
if [[ $DOCS_PDF == "YES" ]]; then make DESTDIR="$pkgdir/" install-pdf; fi
- # remove conflict with ctags package
- mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
-
- if [[ $NOGZ == "YES" ]]; then
- mv "$pkgdir"/usr/share/man/man1/{ctags.1,ctags.emacs.1};
- else
- mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1.gz}
- fi
-
# fix user/root permissions on usr/share files
find "$pkgdir"/usr/share/emacs/ | xargs chown root:root