summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2020-05-07 11:44:04 -0500
committerPedro A. López-Valencia2020-05-07 11:44:04 -0500
commitc1fd68c8c6d30133779992fa4507678303cf44fd (patch)
tree5a7970ae993402e7b9e7f5c83e0352182f439aa2
parentdab3661f666e6200cb7daff604285b97c142daa8 (diff)
downloadaur-c1fd68c8c6d30133779992fa4507678303cf44fd.tar.gz
28.0.50.141102. Make m17n-lib a hard dependency.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD51
2 files changed, 22 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29986c91b7d8..b919b77c1152 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.139945
+ pkgver = 28.0.50.141102
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = emacs-git
depends = gnutls
depends = libxml2
depends = jansson
+ depends = m17n-lib
depends = libotf
depends = harfbuzz
depends = gpm
diff --git a/PKGBUILD b/PKGBUILD
index ed21152c32ab..1a77c440e4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
################################################################################
################################################################################
-# Assign "YES" to the variable you want enabled; empty or other value
+# Assign "YES" to the variable you want enabled; empty or any other value
# for NO.
#
# Where you read experimental, replace with foobar.
@@ -22,6 +22,7 @@
################################################################################
CHECK= # Run tests. May fail, this is developement after all.
CLANG= # Use clang.
+GOLD= # Use the gold linker.
LTO="YES" # Enable link-time optimization. Not that experimental anymore.
# Seems fixed in GCC, so I've reenabled binutils support, please
# report any bug, to make it use clang by default again.
@@ -36,35 +37,25 @@ LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
# Xft, if you choose no toolkit or Lucid.
#
GTK2= # GTK2 support. Why would you?
-M17N= # Enable m17n international table input support.
- # You are far better off using harfbuzz+freetype2
- # But this gives independence if you need it.
- # In fact, right now harfbuzz is hardwired, I have to
- # be convinced it should be refactored.
-CAIRO="YES" # GOOD NEWS! No longer experimental and fully supported.
- # This is now, along with harfbuzz, the prefered font
- # and text shaping engine.
- # If using GTK+, you'll get printing for free.
+NOCAIRO= # Disable here.
XWIDGETS= # Use GTK+ widgets pulled from webkit2gtk. Usable.
DOCS_HTML= # Generate and install html documentation.
DOCS_PDF= # Generate and install pdf documentation.
MAGICK= # ImageMagick 7 support. Deprecated (read the logs).
- # ImageMagick, like flash, is a bug ridden pest that
- # won't die; yet it is useful if you know what you
- #are doing.
- # -->>If you just *believe* you need it, you don't.<<--
+ # ImageMagick, like flash, won't die...
+ # -->>If you just *believe* you need ImageMagick, you don't.<<--
NOGZ="YES" # Don't compress .el files.
################################################################################
################################################################################
pkgname="emacs-git"
-pkgver=28.0.50.139945
+pkgver=28.0.50.141102
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64' )
url="http://www.gnu.org/software/emacs/"
license=('GPL3' )
-depends=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'libotf' 'harfbuzz' 'gpm')
+depends=('alsa-lib' 'gnutls' 'libxml2' 'jansson' 'm17n-lib' 'libotf' 'harfbuzz' 'gpm')
makedepends=('git')
provides=('emacs' 'emacs-seq')
conflicts=('emacs' 'emacs26-git' 'emacs-27-git' 'emacs-seq')
@@ -112,10 +103,6 @@ else
makedepends+=( 'xorgproto' );
fi
-if [[ $M17N == "YES" ]]; then
- depends+=( 'm17n-lib' );
-fi
-
if [[ $MAGICK == "YES" ]]; then
depends+=( 'imagemagick' 'libjpeg-turbo' 'giflib' );
elif [[ ! $NOX == "YES" ]]; then
@@ -124,7 +111,9 @@ else
depends+=();
fi
-if [[ $CAIRO == "YES" ]]; then
+if [[ $NOCAIRO == "YES" ]]; then
+ depends+=( '' );
+else
depends+=( 'cairo' );
fi
@@ -218,18 +207,14 @@ else
_conf+=( '--with-x-toolkit=gtk3' '--without-xaw3d' );
fi
-if [[ ! $M17N == "YES" ]]; then
- _conf+=( '--without-m17n-flt' );
-fi
-
if [[ $MAGICK == "YES" ]]; then
_conf+=( '--with-imagemagick');
else
_conf+=();
fi
-if [[ $CAIRO == "YES" ]]; then
- _conf+=( '--with-cairo' );
+if [[ $NOCAIRO == "YES" ]]; then
+ _conf+=( '--without-cairo' );
fi
if [[ $XWIDGETS == "YES" ]]; then
@@ -243,12 +228,16 @@ fi
################################################################################
- # Use gold with gcc, unconditionally.
+ # Use the gold linker with gcc.
#
- if [[ ! $CLANG == "YES" ]]; then
+ if [[ $GOLD == "YES" && ! $CLANG == "YES" ]]; then
export LD=/usr/bin/ld.gold
- export CFLAGS+=" -s -fuse-ld=gold";
- export CXXFLAGS+=" -s -fuse-ld=gold";
+ export CFLAGS+=" -fuse-ld=gold";
+ export CXXFLAGS+=" -fuse-ld=gold";
+ elif [[ $GOLD == "YES" && $CLANG == "YES" ]]; then
+ echo "";
+ echo "Clang doesn't use gold.ld in this setup.";
+ echo "";
fi
./configure "${_conf[@]}"