summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2020-05-14 17:52:31 -0500
committerPedro A. López-Valencia2020-05-14 17:52:31 -0500
commitd6297889fb115fa84af025ccae1b85c2c46ba7b3 (patch)
tree6ac79b125c8c0dbe9e0ba31953dbc513669a6cf5
parentc1fd68c8c6d30133779992fa4507678303cf44fd (diff)
downloadaur-d6297889fb115fa84af025ccae1b85c2c46ba7b3.tar.gz
28.0.50.141169 Fix NOCAIRO build.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD52
2 files changed, 25 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b919b77c1152..46d9e17f2415 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-git
pkgdesc = GNU Emacs. Development master branch.
- pkgver = 28.0.50.141102
+ pkgver = 28.0.50.141169
pkgrel = 1
url = http://www.gnu.org/software/emacs/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1a77c440e4ab..95613cfb681a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,9 +23,7 @@
CHECK= # Run tests. May fail, this is developement after all.
CLANG= # Use clang.
GOLD= # Use the gold linker.
-LTO="YES" # Enable link-time optimization. Not that experimental anymore.
- # Seems fixed in GCC, so I've reenabled binutils support, please
- # report any bug, to make it use clang by default again.
+LTO= # Enable link-time optimization.
CLI= # CLI only binary.
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
@@ -49,7 +47,7 @@ NOGZ="YES" # Don't compress .el files.
################################################################################
pkgname="emacs-git"
-pkgver=28.0.50.141102
+pkgver=28.0.50.141169
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64' )
@@ -70,12 +68,15 @@ md5sums=('SKIP')
################################################################################
-if [[ $LTO == "YES" ]] && [[ $CLANG != "YES" ]]; then
- CFLAGS+=" -g -flto -fuse-linker-plugin"
- CXXFLAGS+=" -g -flto -fuse-linker-plugin"
-else
- CFLAGS+=" -g -flto"
- CXXFLAGS+=" -g -flto"
+if [[ $GOLD == "YES" && ! $CLANG == "YES" ]]; then
+ export LD=/usr/bin/ld.gold
+ export CFLAGS+=" -fuse-ld=gold";
+ export CXXFLAGS+=" -fuse-ld=gold";
+elif [[ $GOLD == "YES" && $CLANG == "YES" ]]; then
+ echo "";
+ echo "Clang rather uses its own linker.";
+ echo "";
+ exit 1;
fi
if [[ $CLANG == "YES" ]]; then
@@ -90,13 +91,22 @@ if [[ $CLANG == "YES" ]]; then
makedepends+=( 'clang' 'lld' 'llvm') ;
fi
+if [[ $LTO == "YES" ]] && [[ $CLANG != "YES" ]]; then
+ CFLAGS+=" -flto -fuse-linker-plugin"
+ CXXFLAGS+=" -flto -fuse-linker-plugin"
+else
+ CFLAGS+=" -flto"
+ CXXFLAGS+=" -flto"
+fi
+
if [[ $NOTKIT == "YES" ]]; then
- depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' );
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxrandr' 'lcms2' 'librsvg' 'libxfixes' );
+ makedepends+=( 'xorgproto' );
elif [[ $LUCID == "YES" ]]; then
- depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'xorgproto' );
+ depends+=( 'dbus' 'hicolor-icon-theme' 'libxinerama' 'libxfixes' 'lcms2' 'librsvg' 'xaw3d' 'libxrandr' );
makedepends+=( 'xorgproto' );
elif [[ $GTK2 == "YES" ]]; then
- depends+=( 'gtk2' );
+ depends+=( 'gtk2' 'lcms2' );
makedepends+=( 'xorgproto' );
else
depends+=( 'gtk3' );
@@ -111,9 +121,7 @@ else
depends+=();
fi
-if [[ $NOCAIRO == "YES" ]]; then
- depends+=( '' );
-else
+if [[ ! $NOCAIRO == "YES" ]]; then
depends+=( 'cairo' );
fi
@@ -228,18 +236,6 @@ fi
################################################################################
- # Use the gold linker with gcc.
- #
- if [[ $GOLD == "YES" && ! $CLANG == "YES" ]]; then
- export LD=/usr/bin/ld.gold
- export CFLAGS+=" -fuse-ld=gold";
- export CXXFLAGS+=" -fuse-ld=gold";
- elif [[ $GOLD == "YES" && $CLANG == "YES" ]]; then
- echo "";
- echo "Clang doesn't use gold.ld in this setup.";
- echo "";
- fi
-
./configure "${_conf[@]}"
# Using "make" instead of "make bootstrap" enables incremental